Bug 186626 - concerning /etc/nsswitch.conf
concerning /etc/nsswitch.conf
Status: CLOSED DUPLICATE of bug 186592
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
5
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-24 15:13 EST by JeeBee
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-24 16:37:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description JeeBee 2006-03-24 15:13:37 EST
Description of problem:
[root@localhost tmp]# wget google.com
--20:28:59--  http://google.com/
           => `index.html.1'
Resolving google.com... failed: No such file or directory.

Version-Release number of selected component (if applicable):
glibc-2.4-4

How reproducible:
I could only try this once.

Steps to Reproduce:
1. Have a correctly working FC4 installation.
2. Upgrade fedora-release package with rpm.
3. Run 'yum update' without errors and have a FC5 installation with this problem.
  
Additional info:

[root@localhost tmp]# uname -a
Linux foo 2.6.15-1.2054_FC5 #1 Tue Mar 14 15:48:33 EST 2006 i686 athlon
i386 GNU/Linux
[root@localhost tmp]# rpm -q fedora-release wget yum
fedora-release-5-5
wget-1.10.2-3.2.1
yum-2.6.0-1
Comment 1 JeeBee 2006-03-24 15:19:30 EST
Duhhh, sorry, I am not being very clear.
The problem was the "nisplus" in the hosts line in /etc/nsswitch.conf.
  hosts:      files nisplus dns

After removing nisplus there, both wget and 'yum update' worked again.
Comment 2 Jakub Jelinek 2006-03-24 16:37:12 EST

*** This bug has been marked as a duplicate of 186592 ***

Note You need to log in before you can comment on or make changes to this bug.