Bug 186630 - arpwatch does not parse ethercodes.dat correctly
Summary: arpwatch does not parse ethercodes.dat correctly
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: tcpdump   
(Show other bugs)
Version: 5
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Martin Stransky
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-03-24 20:47 UTC by Stephen John Smoogen
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-01 21:59:43 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Stephen John Smoogen 2006-03-24 20:47:49 UTC
Description of problem:

Installed arpwatch 14:2.1a13-14.1.2 from FC5 repository. Started installation
and get the following for all systems found on the network:

    hostname: <unknown>
         ip address: 192.168.1.5
   ethernet address: 0:b0:d0:dd:b3:d1
    ethernet vendor: <unknown>
          timestamp: Thursday, March 23, 2006 18:22:17 -0700

Should have come up as owned by Dell. Looking at the
/var/arpwatch/ethercodes.dat the entry shows 

0:b0:d0 Dell Computer Corp.


Expected results:

Should have reported the system as Dell Computer Corp as it does in FC3.


Additional info:

Comment 1 Martin Stransky 2006-03-28 11:41:53 UTC
Do you have any idea how to reproduce it? It works for me fine...

Comment 2 Stephen John Smoogen 2006-03-28 14:52:23 UTC
I did a fresh install of FC5 with arpwatch. I put the box onto my Linksys WRTG55
router, and did updates. I set up root to aliases to my google.com account. I
started arpwatch and looked at the results. Got what I sent you. I removed
arpwatch and put it back in.. same problem. Changed out the ethercodes.dat with
an updated one.. still same problem. 

Would an strace help any.. I am not thinking it would 

Comment 3 Stephen John Smoogen 2006-04-01 21:59:43 UTC
Bug went away on system after new kernel. I dont think the kernel is the reason
it went away.. but it and the selinux patches are the only updates that have
occured. 

Going to close this as 'stupid computers like me to open useless bugzilla reports'


Note You need to log in before you can comment on or make changes to this bug.