Bug 1866328 - [OSP] openstack cloud name hardcoded to "openstack"
Summary: [OSP] openstack cloud name hardcoded to "openstack"
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 4.6
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.6.0
Assignee: Mike Fedosin
QA Contact: David Sanz
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-08-05 11:21 UTC by David Sanz
Modified: 2020-10-27 16:25 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:24:53 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift installer pull 4010 0 None closed Bug 1866328: use correct cloud name for tfvars 2020-10-01 08:10:29 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:25:10 UTC

Description David Sanz 2020-08-05 11:21:54 UTC
Description of problem:

Running a IPI installation, this error breaks the installation

08-05 13:07:02  level=fatal msg="failed to fetch Terraform Variables: failed to generate asset \"Terraform Variables\": failed to get openstack Terraform variables: Could not retrieve service catalog: cloud openstack does not exist in clouds.yaml"

But there is no reference to "openstack" cloud name on install-config.yaml file and clouds.yaml files



Version-Release number of the following components:
4.6.0-0.nightly-2020-08-05-070245

How reproducible:

Steps to Reproduce:
1.Install IPI on OSP with install-config.yaml file pointing to a cloud not called "openstack"
2.
3.

Actual results:
Installation is not completed

Expected results:

Additional info:
Please attach logs from ansible-playbook with the -vvv flag

Comment 4 David Sanz 2020-08-13 08:59:24 UTC
Verified on 4.6.0-0.nightly-2020-08-12-155346

08-13 06:28:04  level=debug msg="        Loading Cloud Provider Config..."

Comment 6 errata-xmlrpc 2020-10-27 16:24:53 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.