Bug 1866337 - [RHOCS Usability Study][Installation] When creating a Storage Cluster, it was not immediately clear that “Filter by name” was associated with Nodes.
Summary: [RHOCS Usability Study][Installation] When creating a Storage Cluster, it was...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Storage Plugin
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.6.0
Assignee: Vineet
QA Contact: Oded
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-08-05 11:41 UTC by Harish NV Rao
Modified: 2021-06-09 03:14 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:24:53 UTC
Target Upstream Version:


Attachments (Terms of Use)
Search Node UI (70.25 KB, image/png)
2020-09-22 13:48 UTC, Oded
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 6621 0 None closed Bug 1866337: Changes placeholder to 'Search by node name' in install page 2020-11-03 13:55:14 UTC
Github openshift console pull 6746 0 None closed Bug 1866337: Changes placeholder to 'Search by node name/label' in install page 2020-11-03 13:55:14 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:25:10 UTC

Description Harish NV Rao 2020-08-05 11:41:19 UTC
Description of problem:

It was not clear to the users what does “Filter by name” means. Refer to [1] for the screenshot.

UX issue severity level: 4-Low (refer below mentioned doc for severity levels)

This BZ is being filed based on the Usability study conducted on RHOCS during July 2020. A complete report on this Usability study can be found here: https://docs.google.com/presentation/d/1w65Rl2ZsTew-TIqgKUaZ9Y-1DmG1Z4Y59sYQjYC_mMM/edit#slide=id.g547716335e_0_260

[1] https://docs.google.com/presentation/d/1w65Rl2ZsTew-TIqgKUaZ9Y-1DmG1Z4Y59sYQjYC_mMM/edit#slide=id.g8d60435416_0_25


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Bipul Adhikari 2020-08-07 06:32:16 UTC
Assigning to UXD, to suggest a better text that is more user friendly.

Comment 2 Shiri mordechay 2020-08-10 07:48:43 UTC
(In reply to Bipul Adhikari from comment #1)
> Assigning to UXD, to suggest a better text that is more user friendly.

For the text change "Filter by node's name" should be good. 
The problem wasn't only in the text, it is also in the positioning of the search box. this is a gap in the UI implementation that doesn't match the UX design plan. 
Please see in this gaps doc the gaps: https://docs.google.com/document/d/11QMV1Wx63ekf3VXiRSkh6ZDLUuB0Tx3lgFNdgdIe3tk/edit?usp=sharing

If this requires a different BZ, please let me know and I'll open it.

Comment 3 Yuval 2020-08-10 08:09:34 UTC
Maybe "Filter nodes by name"? just changing the order :-)

Comment 4 Shiri mordechay 2020-08-10 08:56:05 UTC
(In reply to Yuval from comment #3)
> Maybe "Filter nodes by name"? just changing the order :-)

Sure, make sense to me.

Comment 5 Ankush Behl 2020-09-07 09:00:39 UTC
@yuval @shiri: How about calling it "Search by Node name"?

As filter "Filter by name" is replaced with "Search by name" in console.

Comment 6 Shiri mordechay 2020-09-07 10:54:29 UTC
(In reply to Ankush Behl from comment #5)
> @yuval @shiri: How about calling it "Search by Node name"?
> 
> As filter "Filter by name" is replaced with "Search by name" in console.

About the Filter vs. Search- select the one that is consistent with all search fields in the console, make sure we're not using different names in different places. 

"Search by node name" sounds good.

Comment 8 Oded 2020-09-22 13:47:11 UTC
I think that we can change to "Search by label..." when search by label

Setup:
Provider:VSphere
OCP Version:4.6.0-0.nightly-2020-09-21-182309


Test Process:
1.Go to "Operators"->"Installed Operators"->"OpenShift Container Storage" -> "Storage Cluster" -> "Create Storage Cluster"
2.There are 2 option to search nodes 
a.Name -> "Search by node name..."
b.Label -> "Search by node name..." (I think that we can change to "Search by label...")
*Attached Screenshot

Comment 9 Oded 2020-09-22 13:48:56 UTC
Created attachment 1715719 [details]
Search Node UI

Comment 10 Harish NV Rao 2020-09-25 05:52:08 UTC
based on https://bugzilla.redhat.com/show_bug.cgi?id=1866337#c8 moving this BZ to assigned state. @vineet please refer to attached screenshot in comment9

Comment 12 Oded 2020-10-06 12:14:41 UTC
Fixed.
Name -> "Search by node name..."
Label -> "Search by node label..."

OCP Version:4.6.0-0.nightly-2020-10-03-051134

Comment 15 errata-xmlrpc 2020-10-27 16:24:53 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.