Bug 1866379 - nodeip-configuration.service service not starting on proxied installations
Summary: nodeip-configuration.service service not starting on proxied installations
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 4.5
Hardware: Unspecified
OS: Unspecified
high
urgent
Target Milestone: ---
: 4.5.z
Assignee: Pierre Prinetti
QA Contact: David Sanz
URL:
Whiteboard:
: 1868178 (view as bug list)
Depends On: 1851344
Blocks: 1849036
TreeView+ depends on / blocked
 
Reported: 2020-08-05 13:07 UTC by David Sanz
Modified: 2020-08-28 09:36 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1851344
Environment:
Last Closed: 2020-08-24 15:13:44 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift machine-config-operator pull 1985 0 None closed Bug 1866379: Pass proxy settings nodeip-configuration service for baremetal, vsphere, openstack 2020-12-18 09:09:10 UTC
Red Hat Knowledge Base (Solution) 5312791 0 None None None 2020-08-11 22:50:30 UTC
Red Hat Product Errata RHBA-2020:3436 0 None None None 2020-08-24 15:14:08 UTC

Comment 1 Abhinav Dahiya 2020-08-11 22:35:18 UTC
*** Bug 1868178 has been marked as a duplicate of this bug. ***

Comment 7 David Sanz 2020-08-13 11:10:13 UTC
Verified on 4.5.0-0.nightly-2020-08-13-101206

NAME                               STATUS   ROLES    AGE     VERSION
mrnd-13-45-px-pswmb-master-0       Ready    master   27m     v1.18.3+2cf11e2
mrnd-13-45-px-pswmb-master-1       Ready    master   27m     v1.18.3+2cf11e2
mrnd-13-45-px-pswmb-master-2       Ready    master   27m     v1.18.3+2cf11e2
mrnd-13-45-px-pswmb-worker-2kwfs   Ready    worker   9m19s   v1.18.3+2cf11e2
mrnd-13-45-px-pswmb-worker-dj2n6   Ready    worker   10m     v1.18.3+2cf11e2
NAME                               PHASE     TYPE           REGION      ZONE   AGE
mrnd-13-45-px-pswmb-master-0       Running   ci.m1.xlarge   regionOne   nova   26m
mrnd-13-45-px-pswmb-master-1       Running   ci.m1.xlarge   regionOne   nova   26m
mrnd-13-45-px-pswmb-master-2       Running   ci.m1.xlarge   regionOne   nova   26m
mrnd-13-45-px-pswmb-worker-2kwfs   Running   ci.m1.xlarge   regionOne   nova   20m
mrnd-13-45-px-pswmb-worker-dj2n6   Running   ci.m1.xlarge   regionOne   nova   20m
NAME                         DESIRED   CURRENT   READY   AVAILABLE   AGE
mrnd-13-45-px-pswmb-worker   2         2         2       2           26m
NAME	  VERSION                             AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.5.0-0.nightly-2020-08-13-101206   True        False         3s      Cluster version is 4.5.0-0.nightly-2020-08-13-101206
NAME                                       VERSION                             AVAILABLE   PROGRESSING   DEGRADED   SINCE
authentication                             4.5.0-0.nightly-2020-08-13-101206   True        False  	 False      18s
cloud-credential                           4.5.0-0.nightly-2020-08-13-101206   True        False         False      27m
cluster-autoscaler                         4.5.0-0.nightly-2020-08-13-101206   True        False         False      14m
config-operator                            4.5.0-0.nightly-2020-08-13-101206   True        False         False      15m
console                                    4.5.0-0.nightly-2020-08-13-101206   True        False  	 True       5m35s
csi-snapshot-controller                    4.5.0-0.nightly-2020-08-13-101206   True 	   False         False      7m54s
dns                                        4.5.0-0.nightly-2020-08-13-101206   True        False         False      25m
etcd                                       4.5.0-0.nightly-2020-08-13-101206   True        False         False      24m
image-registry                             4.5.0-0.nightly-2020-08-13-101206   True 	   False         False      9m16s
ingress                                    4.5.0-0.nightly-2020-08-13-101206   True 	   False         False      8m55s
insights                                   4.5.0-0.nightly-2020-08-13-101206   True        False         False      20m
kube-apiserver                             4.5.0-0.nightly-2020-08-13-101206   True        True          False      23m
kube-controller-manager                    4.5.0-0.nightly-2020-08-13-101206   True        False         False      23m
kube-scheduler                             4.5.0-0.nightly-2020-08-13-101206   True        False         False      23m
kube-storage-version-migrator              4.5.0-0.nightly-2020-08-13-101206   True 	   False         False      9m9s
machine-api                                4.5.0-0.nightly-2020-08-13-101206   True 	   False         False      17m
machine-approver                           4.5.0-0.nightly-2020-08-13-101206   True        False         False      23m
machine-config                             4.5.0-0.nightly-2020-08-13-101206   True 	   False         False      13m
marketplace                                4.5.0-0.nightly-2020-08-13-101206   True        False         False      18m
monitoring                                 4.5.0-0.nightly-2020-08-13-101206   True        False         False      6m31s
network                                    4.5.0-0.nightly-2020-08-13-101206   True        False         False      25m
node-tuning                                4.5.0-0.nightly-2020-08-13-101206   True        False         False      25m
openshift-apiserver                        4.5.0-0.nightly-2020-08-13-101206   True 	   False         False      16m
openshift-controller-manager               4.5.0-0.nightly-2020-08-13-101206   True        False         False      19m
openshift-samples                          4.5.0-0.nightly-2020-08-13-101206   True 	   False         False      12m
operator-lifecycle-manager                 4.5.0-0.nightly-2020-08-13-101206   True        False         False      25m
operator-lifecycle-manager-catalog         4.5.0-0.nightly-2020-08-13-101206   True        False         False      25m
operator-lifecycle-manager-packageserver   4.5.0-0.nightly-2020-08-13-101206   True 	   False         False      4m58s
service-ca                                 4.5.0-0.nightly-2020-08-13-101206   True        False         False      26m
storage                                    4.5.0-0.nightly-2020-08-13-101206   True        False         False      20m

Comment 12 errata-xmlrpc 2020-08-24 15:13:44 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.5.7 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:3436


Note You need to log in before you can comment on or make changes to this bug.