Bug 1866437 - opm should pass skip tls option to pulling index and bundle images
Summary: opm should pass skip tls option to pulling index and bundle images
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: OLM
Version: 4.6
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ---
: 4.6.0
Assignee: Ankita Thomas
QA Contact: Tom Buskey
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-08-05 14:48 UTC by Ankita Thomas
Modified: 2020-10-27 16:25 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:25:04 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github operator-framework operator-registry pull 402 0 None closed Bug 1866437: skip TLS option for pulling indexes 2020-11-25 16:36:56 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:25:24 UTC

Description Ankita Thomas 2020-08-05 14:48:52 UTC
Description of problem:
opm passes skiptls option to bundle image pulls but not to index pulls. Local index images cannot be used because of this

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1. run opm index add with a local index image using skiptls option

Actual results:
Index pull fails because skiptls option is not passed to the pull tool

Expected results:
Index pull succeeds

Comment 3 Tom Buskey 2020-08-24 16:41:25 UTC
opm index add -b quay.io/tbuskey/cockroachdb-bundle:2.0.9,quay.io/tbuskey/cockroachdb-bundle:2.1.1 -t myindex:1 -c podman --skip-tls

podman images
REPOSITORY                                        TAG      IMAGE ID       CREATED              SIZE
localhost/myindex                                 1        62688186b97a   About a minute ago   68.2 MB
quay.io/operator-framework/upstream-opm-builder   latest   d4855ab6520d   4 days ago           67.7 MB
quay.io/tbuskey/cockroachdb-bundle                2.1.1    85e87d3c24dd   4 days ago           17.1 kB
quay.io/tbuskey/cockroachdb-bundle                2.0.9    72027e81ae27   4 days ago           197 kB

opm version
Version: version.Version{OpmVersion:"v1.13.7", GitCommit:"018a040", BuildDate:"2020-08-08T12:13:30Z", GoOs:"linux", GoArch:"amd64"}

podman version
Version:            1.9.3

Comment 5 errata-xmlrpc 2020-10-27 16:25:04 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.