Bug 1866618 - [sriov] Operator admission webhook always set 'deviceType' to 'netDevice
Summary: [sriov] Operator admission webhook always set 'deviceType' to 'netDevice
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Networking
Version: 4.6
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.6.0
Assignee: Peng Liu
QA Contact: zhaozhanqi
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-08-06 04:56 UTC by Peng Liu
Modified: 2020-10-27 16:25 UTC (History)
0 users

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:25:22 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift sriov-network-operator pull 322 0 None closed Bug 1866618: Correct the default 'isRdma' mutation 2020-08-11 03:02:58 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:25:45 UTC

Description Peng Liu 2020-08-06 04:56:49 UTC
Description of problem:
Operator admission webhook always set 'deviceType' to 'netDevice

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Create the following SriovNetworkNodePolicy CR
---
apiVersion: sriovnetwork.openshift.io/v1
kind: SriovNetworkNodePolicy
metadata:
  name: policy-net-2
spec:
  resourceName: nic2
  nodeSelector:
    feature.node.kubernetes.io/network-sriov.capable: "true"
  priority: 51
  mtu: 1500
  numVfs: 4
  nicSelector:
    pfNames: ['ens803f0']
  deviceType: vfio-pci

2.
3.

Actual results:
# oc get sriovnetworknodepolicy policy-net-2 -o yaml
apiVersion: sriovnetwork.openshift.io/v1
kind: SriovNetworkNodePolicy
metadata:
...
spec:
  deviceType: netdevice
  linkType: eth
  mtu: 1500
  nicSelector:
    pfNames:
    - ens803f0
  nodeSelector:
    feature.node.kubernetes.io/network-sriov.capable: "true"
  numVfs: 4
  priority: 51
  resourceName: nic2

Expected results:
# oc get sriovnetworknodepolicy policy-net-2 -o yaml
apiVersion: sriovnetwork.openshift.io/v1
kind: SriovNetworkNodePolicy
metadata:
...
spec:
  deviceType: vfio-pci
  linkType: eth
  mtu: 1500
  nicSelector:
    pfNames:
    - ens803f0
  nodeSelector:
    feature.node.kubernetes.io/network-sriov.capable: "true"
  numVfs: 4
  priority: 51
  resourceName: nic2

Additional info:
Workaround is to disable the operator admission webhook.

Comment 6 errata-xmlrpc 2020-10-27 16:25:22 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.