Bug 186663 - xorg R7 locks up system with PCI Radeon 9200
xorg R7 locks up system with PCI Radeon 9200
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Jackson
: Regression
Depends On:
  Show dependency treegraph
Reported: 2006-03-25 00:39 EST by Rudi Chiarito
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-07-04 09:34:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Crash after coercing the vesa driver (19.17 KB, text/plain)
2006-03-25 00:39 EST, Rudi Chiarito
no flags Details
configuration with vesa driver (2.84 KB, text/plain)
2006-03-25 00:41 EST, Rudi Chiarito
no flags Details
Log of crash with radeon driver (25.94 KB, text/plain)
2006-03-25 00:41 EST, Rudi Chiarito
no flags Details
Configuration using Radeon driver (2.84 KB, text/plain)
2006-03-25 00:42 EST, Rudi Chiarito
no flags Details
Log of crash with int10 module renamed (26.64 KB, text/plain)
2006-03-25 00:45 EST, Rudi Chiarito
no flags Details
Log of crash with int10 module restored, but rawhide radeon driver (26.20 KB, text/plain)
2006-03-25 00:47 EST, Rudi Chiarito
no flags Details

  None (edit)
Description Rudi Chiarito 2006-03-25 00:39:39 EST
Description of problem:
Since the upgrade from FC4 to FC5, the head running on a Radeon 9200 stopped

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Start X
Actual results:
Computer locks up. The keyboard stops working and ping requests are not replied to.

Expected results:
X works as it did under FC4

Additional info:
The system also has a GeForce AGP card that runs the first head using the nv
driver. There were no crashes with FC4.

I am attaching a number of log files and configurations for the several attempts
I made. The last one was made updating to the latest driver rpm package from
xorg-x11-drv-ati- I remounted / with -o sync, in order to
log as much as possible before the crash.
Comment 1 Rudi Chiarito 2006-03-25 00:39:39 EST
Created attachment 126694 [details]
Crash after coercing the vesa driver
Comment 2 Rudi Chiarito 2006-03-25 00:41:08 EST
Created attachment 126695 [details]
configuration with vesa driver
Comment 3 Rudi Chiarito 2006-03-25 00:41:55 EST
Created attachment 126696 [details]
Log of crash with radeon driver
Comment 4 Rudi Chiarito 2006-03-25 00:42:34 EST
Created attachment 126697 [details]
Configuration using Radeon driver
Comment 5 Rudi Chiarito 2006-03-25 00:45:17 EST
Created attachment 126698 [details]
Log of crash with int10 module renamed

Since the last log entry was about the int10 module, I tried to see what
happened if I prevented it from loading. No luck.
Comment 6 Rudi Chiarito 2006-03-25 00:47:21 EST
Created attachment 126699 [details]
Log of crash with int10 module restored, but rawhide radeon driver
Comment 7 Rudi Chiarito 2006-03-29 18:34:45 EST
Being glutton for punishment, I tried several things in order to track down the

I installed the fglrx rpm from Livna. Crash. Maybe it's a kernel problem?

I updated to the 2069 updates-testing kernel. Crash.

I updated to the new 2080 update kernel from today. Crash.

I booted with the latest 2.6.15 kernel from FC4. Crash.

Normally, I would blame this on the hardware, but prior to the FC5 update, the
system had uptimes measured literally in months.
Comment 8 Ingo Schaefer 2006-04-12 03:53:37 EDT

do you have a SMP kernel running?
Is this system from Dell?

Comment 9 Rudi Chiarito 2006-04-20 11:40:33 EDT
Yes, this is a Dell Optiplex GX270. BIOS version is A06 according to dmidecode.
I tried both the SMP and UP kernels (the system has HypeThreading enabled), even
today's freshly released updates.
Comment 10 Rudi Chiarito 2006-05-01 18:29:42 EDT
Is this fixed in any way by https://bugs.freedesktop.org/show_bug.cgi?id=6750 or
https://bugs.freedesktop.org/show_bug.cgi?id=6751? Is there anything from Raw
Hide I can test on FC5 to confirm the bug was fixed?

Comment 11 Mike A. Harris 2006-05-18 20:07:27 EDT
Please uninstall all proprietary drivers from the system, then reinstall
all FC5 xorg and mesa packages to ensure all X server modules you are using
are the ones provided by Fedora Core, and there are no conflicts caused
from the 3rd party drivers.

Ensure that you are using the latest Fedora Core 5 update packages as well,
and nothing from rawhide.

It does appear that int10 is hanging for some reason, so that appears to
be the best place for diagnosis to proceed.  Does the X server just hang
there, but stay in memory livelocked?  Or does the whole system deadlock?

Can you reproduce this from within gdb as root and get a backtrace?
Comment 12 Rudi Chiarito 2006-05-19 11:19:55 EDT
Hello Mike,
the crashes started occurring when I updated the system from FC4 to FC5. The
system always deadlocked, right away, as soon as X blanked the screen when
transitioning from the text console to vt7; there's never been a case when it
didn't freeze entirely. I doubt I can use gdb to debug this.

I didn't install the livna fglrx and the rawhide ati drivers until long after
the crashes occurred; I have since uninstalled them in order to pick up any new
FC5 updates, then I verified with RPM the contents of xorg-*/mesa-* and restored
the old configuration files. According to yum list extras, there's nothing from
Rawhide on the system anymore.

The reason I mentioned Rawhide again is that Dave Airlie made this comment:


"ajax: you might want to consider this for stable, dual-card gets really broken
by later Linux kernels, you have to use this interface on them."

It sounds to me as if there's no hope for me with the existing packages; I am
willing to test more recent ones to debug or confirm the problem has been fixed.
Comment 13 Adam Jackson 2007-05-03 14:57:51 EDT
That patch is already applied for xserver 1.1 and later.

Anyone able to reproduce this with FC6 or FC7?
Comment 14 Matěj Cepl 2007-06-21 08:51:58 EDT
Reporter, could you please confirm whether this bug is still reproducable with
the current versions of either FC6 or FC7? Otherwise, I will have to close this
Comment 15 Matěj Cepl 2007-07-03 09:50:43 EDT
Fedora Core 5 is no longer supported, please, could you reproduce this bug with
the updated version of the currently supported distribution (Fedora Core 6, or
Fedora 7, or Rawhide)? If this issue turns out to still be reproducible, please
let us know in this bug report.  If after a month's time we have not heard back
from you, we will have to close this bug as CANTFIX/INSUFFICIENT_DATA.

Setting status to NEEDINFO, and awaiting information from the reporter.

Thanks in advance.
Comment 16 Rudi Chiarito 2007-07-03 13:21:17 EDT
I no longer have access to the system, so I can't help with this anymore. Feel
free to close the bug.
Comment 17 Matěj Cepl 2007-07-04 09:34:25 EDT
Closing per reporter's request. Please, reopen if you are able to reproduce this
with currently supported distribution.

Note You need to log in before you can comment on or make changes to this bug.