Bug 186675 - copy permissions from source overide destination g+s directory
copy permissions from source overide destination g+s directory
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: nautilus (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
: Security
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-25 04:48 EST by Matthew Wright
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-04 12:13:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Wright 2006-03-25 04:48:18 EST
Description of problem:

There is a bug with nautilus the default copy action is cp -a meaning that if
you have done chmod g+s on a directory, ordinary users can't have the
permissions of the group inherited by copying into a group folder

To get over this I have had to create teh following stuipd cron job in the crontab.

*      *       *       *       *       find /home/shared \! -group shared -exec
chown :shared {} \; -exec chmod u+rw,g+rw {} \;

Version-Release number of selected component (if applicable):


How reproducible:
Every time

Steps to Reproduce:
1. Create a sub directory and set the group ownership ie chown g+s ./mynewdir
2. copy a file from your home directory (make sure the group ownership of
./mynewdir is some other group than your default one in /etc/passwd
3. do an ls -la mynewdir and see that you can't share files like you should be
able to with other members of the groups you belong too.,
  
Actual results:


Expected results:


Additional info:
Comment 1 Alexander Larsson 2006-09-04 12:13:30 EDT
I tried this with the latest rawhide version, and it worked fine. 

Note You need to log in before you can comment on or make changes to this bug.