Bug 1866861 - An image built with the 4.5 operator-registry base should work on 4.6
Summary: An image built with the 4.5 operator-registry base should work on 4.6
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: OLM
Version: 4.6
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
: 4.5.z
Assignee: Evan Cordell
QA Contact: Bruno Andrade
URL:
Whiteboard:
Depends On: 1866860
Blocks: 1857928 1871234 1874797 1879873
TreeView+ depends on / blocked
 
Reported: 2020-08-06 15:36 UTC by Vu Dinh
Modified: 2020-09-17 09:15 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1866860
Environment:
Last Closed: 2020-09-14 14:54:26 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github operator-framework operator-registry pull 434 None closed Bug 1866861: 4.5 index images should work with 4.6 catalog operator. 2020-09-22 14:32:45 UTC
Red Hat Product Errata RHBA-2020:3618 None None None 2020-09-14 14:55:00 UTC

Description Vu Dinh 2020-08-06 15:36:10 UTC
+++ This bug was initially created as a clone of Bug #1866860 +++

Description of problem:
An image built with the 4.5 operator-registry base should work on 4.6.

Version-Release number of selected component (if applicable):
OCP 4.6

How reproducible:
100%

Steps to Reproduce:
1. Deploy an OCP 4.6 cluster
2. Install amq-streams operator via console

Actual results:
amq-streams operator cannot be installed. There is a subscription for amq-streams but no installplan.

Expected results:
amq-streams operator is installed successfully.

Additional info:
At the moment, redhat-operators index image is built with 4.5 registry base image and it is not working correctly.

Comment 16 errata-xmlrpc 2020-09-14 14:54:26 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.5.9 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:3618


Note You need to log in before you can comment on or make changes to this bug.