Bug 1866875 - YAML Editor: Background resource update clears error message
Summary: YAML Editor: Background resource update clears error message
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.6
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.6.0
Assignee: Cyril
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-08-06 17:00 UTC by Samuel Padgett
Modified: 2020-10-27 16:26 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Version: 4.6.0-0.nightly-2020-08-02-134243 Cluster ID: 9130b536-d329-4b30-8a4f-c1814982ef5f Browser: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.15; rv:80.0) Gecko/20100101 Firefox/80.0
Last Closed: 2020-10-27 16:26:10 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 6377 0 None closed Bug 1866875: YAML Editor: Background resource update clears error message 2020-09-11 12:54:23 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:26:14 UTC

Description Samuel Padgett 2020-08-06 17:00:58 UTC
How reproducible:

Always

Steps to Reproduce:

    1. Start editing resource YAML in browser tab 1.
    2. Commit some changes to the same resource in tab 2.
    3. Click save in tab 1. (You get a conflict error.)
    4. Commit some other changes in tab 2.

Actual results:

The error goes away from tab 1.

Expected results:

The error message should not be cleared.

Comment 6 Cyril 2020-08-18 13:20:14 UTC
@Sam Couldn't reproduce this bug in 4.6.0-0.nightly-2020-08-18-055142 cluster. The error message is not cleared in tab 1 - Cannot change resource name (original: "example", updated: "hello"). 

Need more info to reproduce it.

Comment 9 XiaochuanWang 2020-08-24 08:37:50 UTC
The issue is not seen now. After saved the change from one tab, both tabs will show the message "This object has been updated." and it works well when user click Reload button. Content YAML could sync between tabs well.
Verified on 4.6.0-0.nightly-2020-08-23-185640

Comment 10 XiaochuanWang 2020-08-24 08:47:02 UTC
Hi @Sam Is my step correct as yours? Still hope to have your double confirm. Thanks!

Comment 11 Samuel Padgett 2020-09-03 16:28:58 UTC
Hi, you need to try these steps specifically from the description:

    1. Start editing resource YAML in browser tab 1.
    2. Commit some changes to the same resource in tab 2.
    3. Click save in tab 1. (You get a conflict error.)
    4. Commit some other changes in tab 2.

The error message in tab 1 shouldn't disappear. The steps from comment #9 don't look quite right. I would recommend using a ConfigMap.

Moving back to ON_QA.

Comment 12 XiaochuanWang 2020-09-04 01:04:40 UTC
Yes, thanks! Follow above steps and test on 4.6.0-0.nightly-2020-09-03-191144
The issue is not reproduced, moving to Verified.

Comment 14 errata-xmlrpc 2020-10-27 16:26:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.