Bug 1866949 - us-gov-west-1: Error: [ERR]: Error building changeset: NoSuchHostedZone: The specified hosted zone does not exist.
Summary: us-gov-west-1: Error: [ERR]: Error building changeset: NoSuchHostedZone: The ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 4.6
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.6.0
Assignee: Abhinav Dahiya
QA Contact: Yunfei Jiang
URL:
Whiteboard:
: 1867969 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-08-06 22:29 UTC by Jeremiah Stuever
Modified: 2020-10-27 16:26 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:26:26 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift installer pull 4043 0 None closed Bug 1866949: data/data/aws/route53: use CNAME for gov cloud partition 2021-01-20 10:34:52 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:26:29 UTC

Description Jeremiah Stuever 2020-08-06 22:29:19 UTC
Description of problem:

Receive a Terraform error when attempting to install a cluster into AWS govecloud region us-gov-west-1.

Version-Release number of the following components:

$ openshift-install version
openshift-install unreleased-master-3510-g848da04d15e53c89aaca800e9f78dacbae0da50a-dirty
built from commit 848da04d15e53c89aaca800e9f78dacbae0da50a
release image registry.svc.ci.openshift.org/origin/release:4.5

How reproducible:

Always

Steps to Reproduce:
1. openshift-install create install-config
2. Update install-config.yaml to use us-gov-west-1
3. openshift-install create cluster

Actual results:
Please include the entire output from the last TASK line through the end of output if an error is generated

ERROR Error: [ERR]: Error building changeset: NoSuchHostedZone: The specified hosted zone does not exist. 
ERROR   status code: 404, request id: 6c1616d7-b9fb-49b8-b927-b12df43b4271 
ERROR                                              
ERROR   on ../../../tmp/openshift-install-504287315/route53/base.tf line 47, in resource "aws_route53_record" "api_internal": 
ERROR   47: resource "aws_route53_record" "api_internal" { 
ERROR                                              
ERROR                                              
ERROR                                              
ERROR Error: [ERR]: Error building changeset: NoSuchHostedZone: The specified hosted zone does not exist. 
ERROR   status code: 404, request id: 3942235a-22d2-4011-a73b-c2ada0083fd9 
ERROR                                              
ERROR   on ../../../tmp/openshift-install-504287315/route53/base.tf line 59, in resource "aws_route53_record" "api_external_internal_zone": 
ERROR   59: resource "aws_route53_record" "api_external_internal_zone" { 

Expected results:

Terraform should be able to deploy the r53 records without issue.

Additional info:
Please attach logs from ansible-playbook with the -vvv flag

Comment 1 Abhinav Dahiya 2020-08-06 23:22:14 UTC
Can you attach the .openshift_install.log from a run of installer where you see this error with env var TF_LOG=debug set?

Comment 3 Abhinav Dahiya 2020-08-11 17:05:15 UTC
*** Bug 1867969 has been marked as a duplicate of this bug. ***

Comment 4 Wei Sun 2020-08-12 08:19:09 UTC
Adding testblocker keyword since the duplicated bug https://bugzilla.redhat.com/show_bug.cgi?id=1867969 has testblocker keyword, and it's blocking the tests against us-gov cloud is blocked

Comment 8 Yunfei Jiang 2020-08-17 07:31:42 UTC
verified. PASS.
version: 4.6.0-0.nightly-2020-08-16-072105

level=debug msg="module.dns.aws_route53_zone.int: Creation complete after 35s [id=Z08780593O6O0P6FGUUYI]"
level=debug msg="module.dns.aws_route53_record.api_internal_cname[0]: Creation complete after 33s [id=Z08780593O6O0P6FGUUYI_api-int.yun4.qe.devcluster.openshift.com_CNAME]"
level=debug
level=debug msg="module.dns.aws_route53_record.api_external_internal_zone_cname[0]: Creation complete after 33s [id=Z08780593O6O0P6FGUUYI_api.yun4.qe.devcluster.openshift.com_CNAME]"

api-int.yun4.qe.devcluster.openshift.com. and api.yun4.qe.devcluster.openshift.com. were created as CNAME type.

Comment 10 errata-xmlrpc 2020-10-27 16:26:26 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.