Bug 186696 - Can not build a kernel from source 2.6.15-1.2054
Summary: Can not build a kernel from source 2.6.15-1.2054
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel-xen (Show other bugs)
(Show other bugs)
Version: 5
Hardware: x86_64 Linux
medium
high
Target Milestone: ---
Assignee: Juan Quintela
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-03-25 13:51 UTC by Jeff Hoffman
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-21 15:12:48 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jeff Hoffman 2006-03-25 13:51:54 UTC
Description of problem:building kernel from source fails..


Version-Release number of selected component (if applicable):


How reproducible:
very

Steps to Reproduce:
1.rpmbuild -bp --target=`arch` kernel-2.6.spec

First was missing directories xen and xen-vanilla which I added under
/usr/src/redhat/BUILD/kernel-2.6.15


2.Then I reran it and receive this:
[root@one4 SPECS]# rpmbuild -bp --target=`arch` kernel-2.6.spec Building target
platforms: x86_64
Building for target x86_64
Executing(%prep): /bin/sh -e /var/tmp/rpm-tmp.98566
+ umask 022
+ cd /usr/src/redhat/BUILD
+ LANG=C
+ export LANG
+ unset DISPLAY
+ '[' '!' -d kernel-2.6.15/vanilla ']'
+ cd kernel-2.6.15
+ '[' -d linux-2.6.15.x86_64 ']'
+ mv linux-2.6.15.x86_64 deleteme
+ rm -rf deleteme
+ '[' -d xen ']'
+ mv xen deleteme2
+ rm -rf deleteme2
+ cp -rl vanilla linux-2.6.15.x86_64
+ cp -rl xen-vanilla xen
+ cd xen
+ echo 'Patch #20000 (xen-sched-sedf.patch):'
Patch #20000 (xen-sched-sedf.patch):
+ patch -p2 -s
The text leading up to this was:
--------------------------
|Signed-off-by: James Morris <jmorris@redhat.com>
|
|--- xen-3.0.1/xen/common/sched_sedf.c  2006-03-01 17:39:01.000000000 -0500
|+++ xen-3.0.1.w/xen/common/sched_sedf.c        2006-03-13 02:29:18.000000000 -0500
--------------------------
File to patch:

3.
  
Actual results:


Expected results:I was hoping the after the rebuild to add read access to my
ntnfs/DOS file systems..


Additional info:

Comment 1 Daniel Berrange 2007-03-21 15:12:48 UTC
The latest Fedora Core 5 kernel is on 2.6.20 + xen 3.0.3 which builds fine from
source. Since this ticket refers to 2.6.15 + xen 3.0.1 I'm closing it on the
basis that we don't support those older versions anymore


Note You need to log in before you can comment on or make changes to this bug.