Bug 1867066 - Localvolumediscovery detect BIOS Boot as available
Summary: Localvolumediscovery detect BIOS Boot as available
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Storage
Version: 4.6
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.6.0
Assignee: Santosh Pillai
QA Contact: Chao Yang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-08-07 09:58 UTC by Chao Yang
Modified: 2020-10-27 16:26 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:25:54 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift local-storage-operator pull 139 0 None closed Bug 1867066: [Auto-discovery] List BIOS-BOOT and EFI-SYSTEM devices as Unavailable 2020-10-01 08:11:52 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:26:16 UTC

Description Chao Yang 2020-08-07 09:58:31 UTC
Description of problem:
Localvolumediscovery detect BIOS Boot as available

Version-Release number of selected component (if applicable):
4.6.0-0.nightly-2020-08-04-193041
local-storage-operator.4.6.0-202008031851.p0

How reproducible:
Always

Steps to Reproduce:
1.Deploy LSO
2.Create localvolumediscovery
3.Check localvolumediscoveryresult CR
status:
  discoveredDevices:
  - deviceID: /dev/disk/by-id/nvme-Amazon_Elastic_Block_Store_vol08bdf154af19e2fef-part3
    fstype: ""
    model: ""
    path: /dev/nvme0n1p3
    property: NonRotational
    serial: ""
    size: "1048576"
    status:
      state: Available
    type: part
    vendor: ""

4.
sh-4.4# lsblk
NAME                         MAJ:MIN RM   SIZE RO TYPE MOUNTPOINT
loop22                         7:22   0   100M  0 loop 
loop23                         7:23   0   100M  0 loop 
nvme0n1                      259:0    0   120G  0 disk 
|-nvme0n1p1                  259:1    0   384M  0 part /boot
|-nvme0n1p2                  259:2    0   127M  0 part /boot/efi
|-nvme0n1p3                  259:3    0     1M  0 part 
`-nvme0n1p4                  259:4    0 119.5G  0 part 
  `-coreos-luks-root-nocrypt 253:0    0 119.5G  0 dm   /sysroot
fdisk -l
/dev/nvme0n1p3 1048576   1050623      2048     1M BIOS boot
5.Create localvolumeset
spec:
  deviceInclusionSpec:
    deviceTypes:
    - part
    minSize: "0"
  nodeSelector:
    nodeSelectorTerms:
    - matchExpressions:
      - key: kubernetes.io/hostname
        operator: In
        values:
        - ip-10-0-137-193
        - ip-10-0-170-33
        - ip-10-0-199-171
  storageClassName: lvsfile
  volumeMode: Filesystem
status:
  conditions:
  - lastTransitionTime: "2020-08-07T03:42:14Z"
    message: 'DiskMaker: Available, LocalProvisioner: Available'
    status: "True"
    type: DaemonSetsAvailable
  - lastTransitionTime: "2020-08-07T03:42:14Z"
    message: Operator reconciled successfully.
    status: "True"
    type: Available
  observedGeneration: 3
  totalProvisionedDeviceCount: 3
6.PV is provisioned successfully

Actual results:
Localvolumediscovery listed Type BIOS Boot as avaiable

Expected results:
Localvolumediscovery should not list Type BIOS Boot as avaiable

Additional info:

Comment 3 Chao Yang 2020-08-12 07:02:35 UTC
  discoveredDevices:
  - deviceID: /dev/disk/by-id/nvme-Amazon_Elastic_Block_Store_vol0a9e15fa3bf87facb-part3
    fstype: ""
    model: ""
    path: /dev/nvme0n1p3
    property: NonRotational
    serial: ""
    size: "1048576"
    status:
      state: NotAvailable
    type: part
    vendor: ""

oc get csv
NAME                                           DISPLAY         VERSION                 REPLACES   PHASE
local-storage-operator.4.6.0-202008111832.p0   Local Storage   4.6.0-202008111832.p0              Succeeded

Comment 5 errata-xmlrpc 2020-10-27 16:25:54 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.