Bug 1867169 - Updated catalog source serves stale bundles
Summary: Updated catalog source serves stale bundles
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: OLM
Version: 4.5
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: 4.6.0
Assignee: Vu Dinh
QA Contact: Jian Zhang
URL:
Whiteboard:
: 1868143 (view as bug list)
Depends On:
Blocks: 1884861
TreeView+ depends on / blocked
 
Reported: 2020-08-07 14:56 UTC by Daniel Sover
Modified: 2020-11-30 16:46 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-11-30 16:45:28 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github operator-framework operator-lifecycle-manager pull 1715 0 None closed Bug 1867169: Fix stale content in configmap due to stale bundle image in the node 2020-12-16 19:45:36 UTC
Red Hat Product Errata RHBA-2020:5115 0 None None None 2020-11-30 16:46:18 UTC

Comment 7 Jian Zhang 2020-08-19 10:54:37 UTC
Hi Vu,

Many thanks for your details! 

> So in order to see the change in the content, you will need to delete the configmaps.

However, I have conerns about this way. Based on my understanding, the destination of the CatalogSource upgrading is to implement the updgrade of the subscription seamlessly.

To implement that, we use the `Always ImagePullPolicy` to update the CatalogSource image so that the user can use the latest index image if there are updates, and then, use the latest operator Bundle image from the index image. after that, copy the Bundle manifest to a volume.
Now, the fix of this bug is to use the `Always ImagePullPolicy` to make sure we use the latest Bundle image.

> However, after a configmap is created to hold the content of a bundle, it is persistent.

But, due to it's a persistent volume, the lastest Bundle cannot be generated. I'm not very clear here.
But, I think we should fix this issue to implement the seamless update, not let the user remove the ConfigMap manually. Or am I missing something? Thanks!

Comment 15 Jian Zhang 2020-11-02 03:43:06 UTC
Hi Kevin,

Sure, that makes sense. Verify it based on comment 5, 12, 13, 14.

Comment 16 Evan Cordell 2020-11-20 14:25:03 UTC
Note - this was merged while master was still 4.6.0, moving the bug to 4.6.

Comment 17 Evan Cordell 2020-11-20 14:26:48 UTC
*** Bug 1868143 has been marked as a duplicate of this bug. ***

Comment 20 errata-xmlrpc 2020-11-30 16:45:28 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6.6 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:5115


Note You need to log in before you can comment on or make changes to this bug.