Bug 186720 - from gcc 26042: ICE in mark_reference_fields, at java/boehm.c:105
Summary: from gcc 26042: ICE in mark_reference_fields, at java/boehm.c:105
Status: CLOSED DUPLICATE of bug 185553
Alias: None
Product: Fedora
Classification: Fedora
Component: gcc   
(Show other bugs)
Version: 5
Hardware: ppc64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 173278
TreeView+ depends on / blocked
 
Reported: 2006-03-25 17:32 UTC by Andrew Cagney
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-26 05:14:14 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Sourceware 2488 None None None Never
GNU Compiler Collection 26042 None None None Never

Description Andrew Cagney 2006-03-25 17:32:55 UTC
http://gcc.gnu.org/bugzilla/show_bug.cgi?id=26042

This source file, when compiled with gcj produces an ICE:

package x;

class One
{
    long l;    // no ICE if this is int, not long
    int b;     // no ICE if this line is gone; type doesn't matter
}

class Two
{
    class Three extends One { }
    Three three () { return new Three (); }
}

The assertion failure is due to:

          /* If this reference slot appears to overlay a slot we think
             we already covered, then we are doomed.  */
          if (offset <= *last_view_index)
            abort ();

Comment 1 Andrew Cagney 2006-03-26 05:14:14 UTC

*** This bug has been marked as a duplicate of 185553 ***


Note You need to log in before you can comment on or make changes to this bug.