Bug 186729 - Anaconda [Errno 256] while attempting hard disk install using boot.iso
Anaconda [Errno 256] while attempting hard disk install using boot.iso
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: David Cantrell
Depends On:
  Show dependency treegraph
Reported: 2006-03-25 15:43 EST by Eric R. Meyers
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-03-15 13:33:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
This is the dump for the FC4 Upgrade method on Bug 186729 (116.82 KB, text/plain)
2006-05-02 18:43 EDT, Eric R. Meyers
no flags Details
This is the dump for the FC5 Reinstall method on Bug 186729 (46.96 KB, text/plain)
2006-05-02 18:45 EDT, Eric R. Meyers
no flags Details
MYOWN_repomd.xml with some text comment header (1.34 KB, text/plain)
2006-05-03 13:44 EDT, Eric R. Meyers
no flags Details

  None (edit)
Description Eric R. Meyers 2006-03-25 15:43:55 EST
Description of problem:

FC5 Hard disk install failed with Errno 256, "no mirror" available.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. System has 256MB ram
2. FC5 ISO images at /dev/hdb1/ISO/fc5 are verified with sha1sum
3. boot.iso image booted from cdrom drive
4. Selected standard: English, US
5. Anaconda fell back from graphical to text mode.
6. So, also tried alternative directive "linux text acpi=off"
7. Told it Hard Disk named /dev/hdb1 with images in /ISO/fc5
8. Said OK to Fedora hello dialog
9. It went looking for packages, and failed with repodata/repomd.xml [Errno 256]
Actual results:
[Errno 256] "no mirror" available

Expected results:
I expected it to find the ISO images on the Hard Disk in /ISO/fc5.

Additional info:
I couldn't install from Hard Disk with FC4 either.
I thought that I reported bug, but I can't find it.
Comment 1 Nate Faerber 2006-03-25 16:56:16 EST
I've experienced a similar problem trying to install from a DVD.  After I set my
password in graphical mode, I get this error:
Unable to read package metadata. This may be due to a missing repodata
directory. Please ensure that your install tree has been correctly generated.
failure: repodata/repomd.xml from anaconda: [Errno 256] No more mirrors to try.

I've verified the sha1sum on my DVD ISO.  I have run the media test during the
installation.  This is a Dell Latitude CPx with 256MB RAM and a 20GB hard drive.
 The last Fedora installation I have run on it was FC3, I think.

I zero'd out the hard drive before installation and chose the default partition
layout during.  I am getting "media errors" on hdc but I would think the DVD-Rom
drive is fine since it passed the media test.  There errors are:
Buffer I/O error on device hdc, logical block 1588555
hdc: media error (bad sector): status=0x51 { DriveReady SeekComplete Error }
hdc: media error (bad sector): error=0x30 { LastFailedSense=0x03 }
ide: failed opcode was: unknown
end_request: I/O error, dev hdc, sector 6354220
This was repeated many times on the VT at Alt-F4.

I am going to try an install from the DVD ISO stored on a USB attached hard
drive.  This should be extremely slow but it will be interesting if I can get
past the installation prep stage.
Comment 2 Chris Lumens 2006-03-27 11:40:06 EST
Eric - when the installer fails, can you please switch over to tty4 and see if
you are getting the same sorts of error messages as Nate is seeing? 
Unfortunately, it's becoming more and more common that readers are having
trouble with the media.
Comment 3 Eric R. Meyers 2006-03-27 13:56:34 EST
No, I did not see any media error on tty4.
I want to add that I chose to upgrade FC4 and the Grub boot loader, rather than
a fresh install, because I forgot to mention it in this report.
Comment 4 Ghassan Tchelepi 2006-04-25 01:05:49 EDT
I ran into the same problem (errno 256). I was trying to upgrade from FC4 to
FC5. My FC4  is/was a RAID 0 install (worked great), the FC5 upgrade did not
work  (only allows for fresh install ) So I gave up on the upgrade hoping to
install FC5 but that did not work either (errno 256). Had to revert back to FC4.
It appears that FC5 was never tested for an upgrade from FC4 RAID0 install. 
Comment 5 Eric R. Meyers 2006-05-02 18:43:02 EDT
Created attachment 128526 [details]
This is the dump for the FC4 Upgrade method on Bug 186729

try an sdiff with the other one
Comment 6 Eric R. Meyers 2006-05-02 18:45:10 EDT
Created attachment 128527 [details]
This is the dump for the FC5 Reinstall method on Bug 186729

I had to create /mnt/sysimage to mount hdb1 to get to my repository *xml*
Comment 7 Eric R. Meyers 2006-05-02 18:46:56 EDT
I got some more time to work on this problem.  I downloaded the *xml* files of
repodata.  I ran the FC4 Upgrade using "linux text" until the Grubb (*) update
window, and switching to Alt-F2, I poked around a little bit in the shell.  I
did the same with the FC5 Reinstall.

1. /mnt/source was unmounted
2. I saw in Alt-F3 that you're "trying to mount CD device hdc
3. I saw "<7> ISO9660: Extensions Microsoft Joliet Level 3"
4. I saw "<7> ISO9660 Extensions: RRIP_1991A"
5. I saw "dev loop2, type ISO9660"
6. df showed no /dev/hdc mount
7. There was no /dev/hdc, so I did a "mknod /dev/hdc b 3 128"
8. I could not mount /dev/hdc on /mnt/source.  (I don't know, why?)
9. I don't know if /mnt/source was supposed to be a CD device mount (like loop2).
10. I found /mnt/sysimage, and I copied my repodata *xml* to /repodata.
11. This changed the problem, and I have two dumps to floppy for you in this.
12. I can't think of anything else important, except I had the same error
   with the FC Reinstall method, before I started poking around here.
13. I did the same with the FC5 Reinstall, and provide both dumps.

FC4upgrade186729.txt is an ANACDUMP.TXT
FC5reinstall186729.txt is an ANACDUMP.TXT.

The only significant difference was that I had to create /mnt/sysimage and mount
it to my hdb1 for the FC5 Reinstall to get to my repodata and create the
/repodata in your shell's root.

The next thing that I'm going to try is modifying the *xml* files, i.e. the
paths to data.

The FC4upgrade definitely got to the repodata, because the FC5 packages are
listed at the bottom of the dump.
Comment 8 Eric R. Meyers 2006-05-03 08:53:01 EDT
I made various attempts with the paths in repomd.xml and primary.xml.gz, to no
avail. I tried just pointing the repomd.xml to the /mnt/sysimage paths of the
*xml files, and that didn't work. I modified the primary.xml.gz /Fedora/RPMS
path to /mnt/sysimage/.../Fedora/RPMS, and I updated the repomd.xml with the
sha1sum's <open-checksum> (sha1sum primary.xml) and the <checksum> (sha1sum
primary.xml.gz).  And I tried a combination of both methods.  All methods failed
to make it work.
Comment 9 Eric R. Meyers 2006-05-03 13:41:02 EDT
Is the repomd.xml or the primary.xml.gz file for the "Hard Disk ( Reinstall /
Upgrade )" supposed to specify the ISO images in this case, rather than
specifying the /Fedora/RPMS like the primary.xml.gz that I found at the public
mirror site?
If this is so:

Would you please send me the ISO versions of the XML files that I need to go
further, by creating them for me, if you don't already have them on hand?

I'll do it myself if you know what anaconda is looking for in ISO XML files.

Please let me know what you can do to help me.  Thanks!

Here's what I did:

I 'mount /dev/hdb1 /usr/src/redhat' for extra space to build.

I mirrored into /usr/src/redhat/FC5/i386 the 5/i386/iso and 5/i386/os.

In my own repomd.xml, I used the data FROM(...) the following basic commands:

   <checksum type='sha'>FROM(zcat primary.xml.gz | sha1sum)</checksum>
   <open-checksum type='sha'>FROM(sha1sum primary.xml.gz)</open-checksum>
   <timestamp>FROM(ls -l --time-style=+"%s" primary.xml.gz)</timestamp>

I did the CTRL-ALT-F2, and tried 'mkdir repodata; touch repodata/repomd.xml' and
this empty version of repodata/repomd.xml above, is no different in its failure,
than trying to use the original repomd.xml, or a more correct version of
MYOWN_repomd.xml to work as my own repomd.xml.

cp -Rpd /mnt/sysimage/.../repodata .
cd repodata; ln -s MYOWN_repomd.xml repomd.xml

I'm attaching a file called MYOWN_repomd.txt as my own XML example.
Comment 10 Eric R. Meyers 2006-05-03 13:44:18 EDT
Created attachment 128548 [details]
MYOWN_repomd.xml with some text comment header

Please let me know what you can do to help me go further.  Thanks!
Comment 11 David Cantrell 2007-03-15 13:33:57 EDT
The original bug reported here is related to hard disk installs (meaning the
install source is provided by a hard disk partition rather than a CD or network
URL).  We fixed a lot of bugs related to this post-FC6, so please try rawhide or
a Fedora 7 test release.  If the problem is still present, feel free to reopen
the bug.

Note You need to log in before you can comment on or make changes to this bug.