This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 186733 - Sessions - Ask on logout checkbox no longer working in FC5
Sessions - Ask on logout checkbox no longer working in FC5
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: gnome-panel (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-25 17:03 EST by Matthew Wright
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-15 17:51:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
An easy and ugly patch to fix this (550 bytes, patch)
2006-06-07 07:52 EDT, Dmitry Butskoy
no flags Details | Diff

  None (edit)
Description Matthew Wright 2006-03-25 17:03:48 EST
Description of problem:

Gnome-panel Preferences | more preferences | Sessions | Ask on Logout checkbox 
 no longer works, it just does nothing, 

You still get prompted whether you like it or not

Version-Release number of selected component (if applicable):
Lateset gnome-panel gnome-panel-2.14.0-1

How reproducible:
Every time, every user

Steps to Reproduce:
1. goto Sessions
2. uncheck box "Ask on logout"
3. logout
  
Actual results:
You get prompted even though you turned it off.

Expected results:
You should be able to logout and bang you're logged out with no confirmation
dialogs or any other stuff to waste your time.

Additional info:

This worked in FC4
Comment 1 Dmitry Butskoy 2006-06-07 07:10:58 EDT
Yep :(

It is an ugly "end-usering" in the *indows style.

Although it seems to be an upstream issue, maybe fix it at FC locally (at least
for a while)?
Comment 2 Dmitry Butskoy 2006-06-07 07:52:14 EDT
Created attachment 130670 [details]
An easy and ugly patch to fix this

It just set AUTOMATIC_ACTION_TIMEOUT (an internal one-place-used macro in
panel-logout.c file) to zero :)
Comment 3 Kevin Cozens 2006-09-28 19:54:13 EDT
I have noticed the same problem. Under FC4 I was able to tick a checkbox at log
out to save my current session. No matter what I have tried so far, I can not
get FC5 (running Gnome) to give me the option of saving my session on log out.
As a result, I have had to stick to using "save session always" which is not
what I really want. I want to be able to "snapshot" my current session set up
and have it reppear the next time I log in.
Comment 4 Ray Strode [halfline] 2007-08-15 17:51:55 EDT
this is fixed now, I believe.  I just set the logout_prompt key to false and i
didn't get a dialog.

Note You need to log in before you can comment on or make changes to this bug.