Bug 186734 - anaconda does listen to what packages I tell to not install
anaconda does listen to what packages I tell to not install
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
5
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Paul Nasrat
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-25 17:07 EST by Jason
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-29 17:22:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
install.log (26.11 KB, text/plain)
2006-03-27 14:49 EST, Jason
no flags Details
anaconda.log (23.34 KB, text/plain)
2006-03-27 14:50 EST, Jason
no flags Details

  None (edit)
Description Jason 2006-03-25 17:07:24 EST
Description of problem:
I install FC5 on Friday.  I told anaconda not to install tomboy, beagle,
gnome-user-share (I don't want httpd installed on my home PC) and a couple of
other packages.  After the install tomboy, beagle, and the others were there.  I
don't it is a dependency problem because I did a rpm -e tomboy and nothing
complained.

Version-Release number of selected component (if applicable):
whatever version is in fc5

How reproducible:
always

Steps to Reproduce:
1. start an install
2. deselect tomboy and begale and gnome-user-share
3. watch as they get installed
  
Actual results:
packages I told anaconda NOT to install got installed

Expected results:
tomboy, beagle, gnome-user-share, httpd should NOT have been installed.

Additional info:
Comment 1 Jeremy Katz 2006-03-27 13:17:56 EST
Can you provide /root/install.log and /var/log/anaconda.log?
Comment 2 Jason 2006-03-27 14:49:04 EST
Created attachment 126848 [details]
install.log
Comment 3 Jason 2006-03-27 14:50:54 EST
Created attachment 126849 [details]
anaconda.log
Comment 4 Devin 2006-04-14 06:01:54 EDT
It isn't just the packages you ask anaconda not to install.  Anaconda also
doesn't listen when you ask it to install packages it doesn't install by
default, and the results can be seen immediately after choosing certain packages.

(I'm using text mode due to problems with graphical installation.  This could be
a text mode specific problem.)

For example:

1.) At the point in the installation where you select package groups you would
like installed, highlight the 'Editors' section
2.) Press 'F2' to see the package group details
3.) Deselect a package (I chose 'vim-enhanced', the only selected package)
4.) Select a package (i.e. 'emacs')
5.) Tab to the 'OK' button and hit Enter
6.) Press 'F2' again to review the choices you just made, and note that the
choices have been reset to their defaults
Comment 5 Jason 2006-08-29 17:22:50 EDT
I installed rawhide and the problem seems to have gotten fixed between then and
now.  I am closing the bug.

Note You need to log in before you can comment on or make changes to this bug.