Bug 186741 - serefpolicy 20060323 (2.2.26-1) is locking kernel?
serefpolicy 20060323 (2.2.26-1) is locking kernel?
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: selinux-policy-targeted (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Russell Coker
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-25 19:41 EST by Robert Scheck
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-03 12:44:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Scheck 2006-03-25 19:41:09 EST
Description of problem:
Modular policy (serefpolicy) seems to be broken, because when updated to 2.2.26 
once, I can't switch to any other policy (even no downgrade) without rebooting 
the whole system.

Error when trying to downgrade to 2.2.24:
  /usr/sbin/load_policy:  Can't load policy:  Invalid argument
  libsemanage.semanage_reload_policy: load_policy returned error code 2.
  semodule:  Failed!

Undiffing http://cvs.sourceforge.net/viewcvs.py/serefpolicy/refpolicy/policy/
support/loadable_module.spt?r1=1.14&r2=1.15 seems to work around the problem.

Erich from Freenode #selinux already sent a testcase to Stephen, but he didn't 
answer yet. This is maybe a kernel bug, because the policy is correct, but the 
kernel seems to be locked up avoiding to apply a new policy - which only works 
during a reboot (for the moment).

Version-Release number of selected component (if applicable):
selinux-policy-targeted-2.2.26-1

How reproducible:
Everytime, see above.

Actual results:
Broken stuff as described above.

Expected results:
Working like in the past ;-)

Additional info:
There are thousands of avc denieds in my syslog (nearly everything is claimed), 
because of this...and would be very nice to get master of the situation in a 
sane way very soon.
Comment 1 Daniel Walsh 2006-04-03 12:44:36 EDT
Fixed by updates to libsemanage-1.6.2-2

Note You need to log in before you can comment on or make changes to this bug.