Bug 186743 - /etc/localtime is a copy from /usr/share/zoneinfo - should be a symlink
/etc/localtime is a copy from /usr/share/zoneinfo - should be a symlink
Status: CLOSED DUPLICATE of bug 186742
Product: Fedora
Classification: Fedora
Component: tzdata (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Petr Machata
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-25 19:54 EST by lannet
Modified: 2015-05-04 21:32 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-29 05:07:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description lannet 2006-03-25 19:54:19 EST
Description of problem:
Daylight changing has occured at the wrong date (Australia eastern states)


Version-Release number of selected component (if applicable):
All versions of FC inc FC5


How reproducible:
Very


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
During installation, /etc/localtime is taken as a copy from the selected zone
file in /usr/share/zoneinfo
Consequently, when the tzdata package gets updated, as has happened in
Australian eastern states to reflect the change from daylight saving being 1
week later to accommodate the Commonwealth Games, the /etc/localtime file does
not get updated.
Surely /etc/localtime should be a symlink into the selected /usr/share/zoneinfo
file instead of being a copy from it.
I have just checked this with an FC5 install and it is still a copy - reflecting
the correct change point because the tzdata file is new - but it will never
reflect any future changes to tzdata files.
Comment 1 Danny Yee 2006-03-26 17:22:54 EST
On a few of our FC4 machines /etc/localtime had been updated -- possibly on a
reboot, or possibly on some other trigger.

Can someone confirm how the FC system is supposed to work - are there meant to
be symlinks, or should tzdata RPMs update /etc/localtime in their post-install
scripts?
Comment 2 lannet 2006-03-26 23:21:35 EST
It has been commented elsewhere that a symlink between /etc/localtime and the
zoneinfo file in /usr/share/zoneinfo may not be the best way to go as there may
be situations where the latter filesystem may not be on line when the local time
gets set during boot.

Perhaps some sort of intermediary using /etc/sysconfig might be a better way to go.
Comment 3 Petr Machata 2006-03-29 05:07:21 EST

*** This bug has been marked as a duplicate of 186742 ***

Note You need to log in before you can comment on or make changes to this bug.