Bug 186752 - kernel problem to deal with 3ware 9500SX-12 RAID cards
kernel problem to deal with 3ware 9500SX-12 RAID cards
Status: CLOSED DUPLICATE of bug 186751
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.0
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-25 21:14 EST by Robinson Tiemuqinke
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-27 11:11:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robinson Tiemuqinke 2006-03-25 21:14:58 EST
Description of problem:
 
The default kernel for ES 4.2 could not detect 3ware 9500SX-12 RAID card. 
after download the 9.3.0.3 driver from 3ware.com and compiled against the 
default kernel, it reports odd problems.


Version-Release number of selected component (if applicable):
kernel-2.6.9-22.EL
kernel-smp-2.6.9-22.EL

How reproducible:

Every time.


Steps to Reproduce:
1. Install a Redhat Enterprise 4 Update 2 machine with the CDs or ISO files.

2. boot the machine up but it doesn't report the drives behind 3ware 9500SX-12 
RAID cards.

3. download the driver from 3ware.com and compile it, load it with insmod, it 
detects the drives. But reports lots of erros in /var/log/messages regarding 
the size. error messages are attached.
  

Actual results:

[root@testnode01 ~]# lspci | grep -i raid
01:01.0 RAID bus controller: 3ware Inc: Unknown device 1003
01:03.0 RAID bus controller: 3ware Inc 7xxx/8xxx-series PATA/SATA-RAID (rev 01)
02:01.0 RAID bus controller: 3ware Inc: Unknown device 1003

[root@testnode01 ~]# lspci -n | grep 13c1
01:01.0 Class 0104: 13c1:1003
01:03.0 Class 0104: 13c1:1001 (rev 01)
02:01.0 Class 0104: 13c1:1003

[root@testnode01 ~]# cat /var/log/messages |less
...
Mar 23 19:31:56 testnode01 kernel: scsi2 : 3ware 9000 Storage Controller
Mar 23 19:31:56 testnode01 kernel: 3w-9xxx: scsi2: Found a 3ware 9000 Storage 
Controller at 0xfc3fe000, IRQ: 225.
Mar 23 19:31:56 testnode01 kernel: 3w-9xxx: scsi2: Firmware FE9X 3.02.00.016, 
BIOS BE9X 3.01.00.027, Ports: 12.
Mar 23 19:31:56 testnode01 kernel:   Vendor: AMCC      Model: 9550SX-12  
DISK   Rev: 3.02
Mar 23 19:31:56 testnode01 kernel:   Type:   Direct-
Access                      ANSI SCSI revision: 03
Mar 23 19:31:56 testnode01 kernel: sdc : very big device. try to use READ 
CAPACITY(16).
Mar 23 19:31:56 testnode01 kernel: SCSI device sdc: 4687368192 512-byte hdwr 
sectors (2399933 MB)
Mar 23 19:31:56 testnode01 kernel: SCSI device sdc: drive cache: write back, 
no read (daft)
Mar 23 19:31:56 testnode01 kernel:  sdc: unknown partition table
Mar 23 19:31:56 testnode01 kernel: Attached scsi disk sdc at scsi2, channel 0, 
id 0, lun 0
Mar 23 19:31:56 testnode01 kernel: scsi: On host 2 channel 0 id 0 only 511 
(max_scsi_report_luns) of 239988206 luns reported, try increasing 
max_scsi_report_luns.
Mar 23 19:31:56 testnode01 kernel: scsi: host 2 channel 0 id 0 lun 
0x20726f6f74667320 has a LUN larger than currently supported.
Mar 23 19:31:56 testnode01 kernel: scsi: host 2 channel 0 id 0 lun 
0x7277203020300a2f has a LUN larger than currently supported.
...



Expected results:



Additional info:
Comment 1 Jason Baron 2006-03-27 11:11:35 EST

*** This bug has been marked as a duplicate of 186751 ***

Note You need to log in before you can comment on or make changes to this bug.