Bug 186754 - ia32el: opendir() not open the correct directory if the directory name can be found in /emul/ia32-linux directory
Summary: ia32el: opendir() not open the correct directory if the directory name can be...
Status: CLOSED DUPLICATE of bug 186757
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: ia32el   
(Show other bugs)
Version: 4.0
Hardware: ia64 Linux
medium
high
Target Milestone: ---
: ---
Assignee: Petr Machata
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-03-26 03:16 UTC by joan
Modified: 2015-05-05 01:32 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-27 09:27:05 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description joan 2006-03-26 03:16:44 UTC
Description of problem:
opendir() work abnormal with ia32el service.

Version-Release number of selected component (if applicable):
1.3.2

How reproducible:
Use opendir(), whenever we pass a absolute path name(eg./usr/share)or relative 
path name, it will try to open the path on /emul/ia32-linux/usr/share first, if 
the directory is not exist on /emul/ia32-linux/, then it going to 
open /usr/share, this is the key. 


Steps to Reproduce:
1.
2.
3.
  
Actual results:
opendir() not open the correct direcotry if the directory also exists 
in /emul/ia32-linux/ directory. This will cause the 32bit program work abnormal 
in 64bit environment.

Expected results:
opendir() can open the correct directory on ia64 platform.



Additional info:

Comment 1 Jakub Jelinek 2006-03-27 09:27:05 UTC

*** This bug has been marked as a duplicate of 186757 ***


Note You need to log in before you can comment on or make changes to this bug.