Bug 186758 - opendir() work abnormal with ia32el service
opendir() work abnormal with ia32el service
Status: CLOSED DUPLICATE of bug 186757
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: ia32el (Show other bugs)
4.0
ia64 Linux
medium Severity medium
: ---
: ---
Assigned To: Petr Machata
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-25 22:24 EST by joan
Modified: 2015-05-04 21:32 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-27 04:25:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description joan 2006-03-25 22:24:26 EST
Description of problem:
opendir() work abnormal with ia32el service.

Version-Release number of selected component (if applicable):
ia32el 1.3.2
Redhat Enterprise Linux 4, U1, U2,U3

How reproducible:
Use opendir(), whenever we pass a absolute path name(eg./usr/share)or relative 
path name, it will try to open the path on /emul/ia32-linux/usr/share first, if 
the directory is not exist on /emul/ia32-linux/, then it going to 
open /usr/share. 
This will cause the 32bit program work abnormal in 64bit environment.


Steps to Reproduce:
1.
2.
3.
  
Actual results:
opendir() not open the correct direcotry if the directory also exists 
in /emul/ia32-linux/ directory. 

Expected results:
opendir() can open the correct directory on ia64 platform.

Additional info:
Comment 1 Jakub Jelinek 2006-03-27 04:25:04 EST

*** This bug has been marked as a duplicate of 186757 ***

Note You need to log in before you can comment on or make changes to this bug.