Bug 186777 - Eastern Australia requires urgent update to zoneinfo files
Eastern Australia requires urgent update to zoneinfo files
Status: CLOSED DUPLICATE of bug 186742
Product: Fedora
Classification: Fedora
Component: tzdata (Show other bugs)
4
All Linux
medium Severity low
: ---
: ---
Assigned To: Petr Machata
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-26 07:15 EST by Burn Alting
Modified: 2015-05-04 21:32 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-06 09:41:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Burn Alting 2006-03-26 07:15:42 EST
Description of problem:
In the Eastern Australian states which use daylight savings, the change in 2006
is 2nd April due to the commonwealth games.

Version-Release number of selected component (if applicable):


How reproducible:
Type date

Steps to Reproduce:
1.Type date
2.
3.
  
Actual results:
Daylight savings has changed on the computer.

Expected results:
Expected an updated zoneinfo file before today!

Additional info:
Since zoneinfo was not part of components, I used the date configh tool. There
is nothing wrong with this, but the data base needs urgent updating.
Comment 1 Burn Alting 2006-03-27 17:11:07 EST
Problem resolved via a reboot of system.

As an aside, I was running tzdata-2006b-2.fc4 when this happened.

Perhaps someone needs to test the on-line date representation with daylight
savings changes.
Comment 2 Need Real Name 2006-04-03 15:33:07 EDT
Mark as NOTABUG?
Comment 3 Burn Alting 2006-04-03 18:19:55 EDT
I think it's priority can go down, but it's still a bug.

Assuming that tzdata-2006b-2.fc4 had the April 2 change for Australia, then it
is a problem if one needs to reboot their system after applying a change to the
zoneinfo data sets.
Comment 4 Nils Philippsen 2006-04-04 06:15:12 EDT
I can't see what this has to do with system-config-date, changing component to
tzdata.
Comment 5 Burn Alting 2006-04-04 07:02:02 EDT
Quite correct Nils, when I listed the bug I didn't know it was the tzdata
package and looked for anything to do with time in the pull down menu and config
date was the closest (to my, then, ignorant mind).

Comment 6 Petr Machata 2006-04-04 07:13:28 EDT
Did you ran system-config-date after the package got updated? This needs to be
done for timezone info to be copied.
(Maybe duplicate of #186742?)
Comment 7 Burn Alting 2006-04-04 07:28:22 EDT
I think I may have. I have read 186742 and tend to believe my bug is a duplicate
of 186742. The effect is the same. I thought a reboot corrected the problem, but
executing config-date before the reboot may have been the 'real fix'.
Comment 8 Nils Philippsen 2006-04-04 10:43:30 EDT
Petr, as per my mail to fedora-devel-list, I'd propose to put the updating of
/etc/localtime into tzdata, i.e. in the %post script see if ZONE in
/etc/sysconfig/clock is a valid (i.e. not "custom" and exists beneath
/usr/share/zoneinfo) and copy it over /etc/localtime. In order to not get people
confused I'd change s-c-date to add a comment like '# Set ZONE="custom" if you
don't want the timezone to be updated automatically'.

Would you accept a patch?
Comment 9 Petr Machata 2006-04-06 09:41:04 EDT

*** This bug has been marked as a duplicate of 186742 ***

Note You need to log in before you can comment on or make changes to this bug.