Bug 1867864 - Set Traffic should not allow the user to specify the same revision twice
Summary: Set Traffic should not allow the user to specify the same revision twice
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.5
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.6.0
Assignee: Aritra Roy
QA Contact: Gajanan More
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-08-11 04:31 UTC by Aritra Roy
Modified: 2020-10-27 16:27 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:27:30 UTC
Target Upstream Version:


Attachments (Terms of Use)
restrict selecting the same revision more than once in traffic modal (720.67 KB, image/gif)
2020-08-11 04:31 UTC, Aritra Roy
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 6286 0 None closed Bug 1867864: restrict multiple selections of a revision in traffic modal 2020-08-24 10:41:29 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:27:43 UTC

Description Aritra Roy 2020-08-11 04:31:04 UTC
Created attachment 1711034 [details]
restrict selecting the same revision more than once in traffic modal

Description of problem:
a revision can be assigned traffic multiple times in traffic distribution modal

Version-Release number of selected component (if applicable):
4.6.0-0.nightly-2020-08-02-091622

How reproducible:
always

Steps to Reproduce:
1.Create a knative service
2.click on `Set Traffic Distribution` from the topology sidebar
3.add a traffic field using the `+Add` button
4.select a revision from the revision name dropdown

Actual results:
the revision that has been already selected can be seen in the dropdown options

Expected results:
the revisions already selected should not appear in the dropdown options

Additional info:

Comment 3 Gajanan More 2020-08-24 10:52:40 UTC
I have validated the bug on:

Build: 4.6.0-0.nightly-2020-08-23-214712

Browser: Google Chrome Version 84.0.4147.89 

Marking this as done.

Comment 5 errata-xmlrpc 2020-10-27 16:27:30 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.