Bug 186787 - Pirut (and pup also) are hellish unresponsive when downloading packages
Pirut (and pup also) are hellish unresponsive when downloading packages
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
5
All Linux
medium Severity low
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-26 08:58 EST by Sven Kromminga
Modified: 2008-08-02 19:40 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-11 17:50:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Sven Kromminga 2006-03-26 08:58:49 EST
Description of problem:
Pirut (and pup also) are very unresponsive when downloading packages.
While downloading the gui and the progress-window are not redrawn. 
I think some users can become confused and think the 
prog died. 

Version-Release number of selected component (if applicable):
latest

How reproducible:
by running pirut or pup

Steps to Reproduce:
s.a.
  
Actual results:
pirut and pup are very unresponsive

Expected results:
The gui and especially the progress-bar should be redrawn, so the user
still nows something is going on. 

Additional info:
Comment 1 Jeremy Katz 2006-04-12 13:37:47 EDT
It's pretty responsive for me here.  What sort of network connection do you have
and where are you pulling from?

The only way I can really see that it wouldn't be updated relatively
"frequently" is if the server isn't returning the size of the packages being
downloaded.  

Also, if it's a really slow straw, then it could be infrequent -- I added
something so that it will update once a second as long as we're getting the size.
Comment 2 Jon Levell 2006-04-18 15:31:55 EDT
Though I'm not the original reporter, I think I'm seeing the same issue. If I
have  Pup downloading updates and am doing other things with my computer I
sometimes notice (via the GNOME applet that the network activity has died away
earlier than I expect) if I switch to the Pup window it never (and I have left
it for more than an hour) redraws its screen, I'm not sure whether it crashes or
a mirror has dropped connection and it never recovers or...? I don't experience
similar problems with yum and my network connection is mediocre (512Kb home
ADSL). (I use the standard repos + livna)

Not able to reliably reproduce this but I'm happy to run with extra logging etc.
for a while if you explain to me (assume I'm a complete idiot) how.
Comment 3 Adrien Bustany 2006-05-10 13:48:16 EDT
Pup and pirut should create a thread, so that the gtk event loop could occur
even when download stalls. This would avoid these hangs...
Comment 4 drago01 2006-06-24 02:30:22 EDT
(In reply to comment #3)
> Pup and pirut should create a thread, so that the gtk event loop could occur
> even when download stalls. This would avoid these hangs...
there is a thread in the devel list about this:
http://www.redhat.com/archives/fedora-devel-list/2006-June/msg00529.html
for me in FC6T1 pup seems never to redraw the download window.
I have a cable connection 4Mbit and and it is downloading with ~400Kb/s now
(used gnome-system-monitor to check)
Comment 5 Jeremy Katz 2006-09-11 17:50:41 EDT
In FC6 test releases, the download progress bar was never getting set due to a
yum bug -- I've fixed that up in yum CVS

I've also changed things so that the progress bar will be updated for every 8k
downloaded or every half a second, whichever is longer.

Note You need to log in before you can comment on or make changes to this bug.