Bug 18680 - Autorun, Auto mount or Cd_ROM errors!!!
Autorun, Auto mount or Cd_ROM errors!!!
Status: CLOSED DUPLICATE of bug 13628
Product: Red Hat Linux
Classification: Retired
Component: magicdev (Show other bugs)
7.0
i386 Linux
high Severity high
: ---
: ---
Assigned To: Aaron Brown
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-09 02:44 EDT by Need Real Name
Modified: 2005-10-31 17:00 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-29 16:34:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2000-10-09 02:44:51 EDT
Hi 
Could you see to it that the correct person gets this.

I have two systems the one I recently upgraded from rh6.2 to rh7 and know 
I can't read some CD-ROMs on the system. This was not the case with rh6.2 
or rh6.1 I take it that this is a bug with your new enhancement that you 
don't have to unmount the CDROM to remove it (which by the way is a pretty 
nice enhancement.)
And what makes me sure it is a bug is the fact that I made a fresh 
installation on my other system a IBM 300PL and I have the same problems.

The errors include:
Not showing al the files on the CD-ROM.
Not displaying the names of the files or directories on the CD-ROM.
Not being able to mount the CD-ROM error bad supperblok.

What is strange is that on my first system I have a HP9300 CD writer on 
the secondary IDE as master and a LG 48X8 DVD_ROM on the same IDE Channel 
as slave, and I only have this problem on the HP9300.

PS. I was using a GNOME desktop so it could be that but I doubt it.

Thanks
Frederik
Comment 1 Harald Hoyer 2000-10-10 09:55:46 EDT
I think this is magicdev related as the GNOME desktop is used.
Comment 2 Dale Lovelace 2000-10-10 10:17:16 EDT
Could you try this:

1. reboot
2. Insert a data CD into each of your CD drives
3. Log in/Start X
4. Check for the same errors you are describing here.

  Then try this:

1. Open your Gnome control center (the toolbox icon on the Gnome Panel)
2. Under "Peripherals" click "CD Properties"
3. Uncheck these:
	Automatically mount CD when inserted
	Automatically start auto-run program on newly inserted CD
	Open file manager window for newly mounted CD
	Run command when CD is inserted
4. Click OK
5. Reboot your machine with NO CD's in your CD drives.
6. Login/Start X and check for these errors.

  If you could try these and report what errors you get in each of these
situations it would be very helpful.

  Thanks!
Comment 3 JackHung 2000-10-19 03:26:58 EDT
I do have similary problem. If i logon as root and insert say the distribution
CD, it "auto" mounts OK.
But if i logon as a normal user, i fail to mount any CD.
Comment 4 Need Real Name 2000-10-19 14:10:54 EDT
Hi

I don't no, will need to reboot to RH7. But I did found what was causing the 
problem: If I press the physical open/close button when a Cd was mounted and 
inserted another Cd, I could not read all of it's contents, but if I right 
clicked on the CDROM icon and eject the Cd from the desktop and then reinserted 
the Cd I could read it fine. So for now I'm staying clear of the open/close 
button. Try it on your system and let me know if you can duplicate the error.

PS. With previous versions of RH I could not open the CDROM without unmounting 
it first.

Hope this helps, I have not jet used the CDROM as a normal user.

Cheers
Kammies
Comment 5 Need Real Name 2000-10-25 16:08:28 EDT
Hi Dale

I have tryed wat you recomended but I still get the same errors, dit you see my 
previous report:"I don't no, will need to reboot to RH7. But I did found what 
was causing the 
problem: If I press the physical open/close button when a Cd was mounted and 
inserted another Cd, I could not read all of it's contents, but if I right 
clicked on the CDROM icon and eject the Cd from the desktop and then reinserted 
the Cd I could read it fine. So for now I'm staying clear of the open/close 
button. Try it on your system and let me know if you can duplicate the error.

PS. With previous versions of RH I could not open the CDROM without unmounting 
it first."
Let me know.


Thanks
Frederik
Comment 6 Jojo 2000-11-16 09:25:57 EST
I do pretty much have the same problems it only seems that it only happens with
the second CD i instert  (i put in one cd --works fine; take it out put in
another -- errors , lots of errors and not all of the cds contents shon
afterwards)  but ill try the thing with not touching the ejector button maybe
that is the problem.
Comment 7 Owen Taylor 2001-02-07 18:08:04 EST

*** This bug has been marked as a duplicate of 13628 ***

Note You need to log in before you can comment on or make changes to this bug.