Bug 1868002 - python root, ROOT cannot be imported , import libcppyy2_7. Please check that ROOT has been built for Python 2.7
Summary: python root, ROOT cannot be imported , import libcppyy2_7. Please check that ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: root
Version: epel7
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Mattias Ellert
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-08-11 11:45 UTC by Steve Traylen
Modified: 2020-08-25 00:36 UTC (History)
1 user (show)

Fixed In Version: root-6.22.00-5.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-08-25 00:36:27 UTC
Type: Bug


Attachments (Terms of Use)

Description Steve Traylen 2020-08-11 11:45:24 UTC
Description of problem:

ROOT cannot be imported with EPEL7


Version-Release number of selected component (if applicable):

python2-root-6.22.00-2.el7.x86_64
root-6.22.00-2.el7.x86_64


How reproducible:

Every time

Steps to Reproduce:
1. python
2. python > import ROOT
3.

Actual results:

Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "/usr/lib64/python2.7/site-packages/ROOT/__init__.py", line 34, in <module>
    import cppyy
  File "/usr/lib64/python2.7/site-packages/cppyy/__init__.py", line 64, in <module>
    libcppyy_mod_name, major, minor))
ImportError: Failed to import libcppyy2_7. Please check that ROOT has been built for Python 2.7


Expected results:

It should import.

Additional info:

This looks suspicious:


# ls -l  /usr/lib64/python*/site-packages/libcppyy*.so                                                                                          
lrwxrwxrwx. 1 root root 33 Jul 18 04:58 /usr/lib64/python2.7/site-packages/libcppyy2_7.so -> ../../root/libcppyy3_6.so.6.22.00
lrwxrwxrwx. 1 root root 41 Jul 18 04:58 /usr/lib64/python2.7/site-packages/libcppyy_backend2_7.so -> ../../root/libcppyy_backend3_6.so.6.22.00
lrwxrwxrwx. 1 root root 33 Jul 18 04:58 /usr/lib64/python3.6/site-packages/libcppyy3_6.cpython-36m-x86_64-linux-gnu.so -> ../../root/libcppyy3_6.so.6.22.00
lrwxrwxrwx. 1 root root 41 Jul 18 04:58 /usr/lib64/python3.6/site-packages/libcppyy_backend3_6.so -> ../../root/libcppyy_backend3_6.so.6.22.00

They all symlink to the 3.6 backend.

Indeed if I force the recreation of the symlinks:

cd /usr/lib64/python2.7/site-packages

ln -sf ../../root/libcppyy2_7.so.6.22.00 libcppyy2_7.so 
ln -sf ../../root/libcppyy_backend2_7.so.6.22.00 libcppyy_backend2_7.so 


Then the import of ROOT with default python (2.7) is fine.

Comment 1 Fedora Update System 2020-08-12 15:56:55 UTC
FEDORA-EPEL-2020-042f5b5af8 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2020-042f5b5af8

Comment 2 Mattias Ellert 2020-08-12 16:36:30 UTC
Thank you. Stupid cut and paste error in specfile corrected.

Comment 3 Fedora Update System 2020-08-13 02:31:56 UTC
FEDORA-EPEL-2020-042f5b5af8 has been pushed to the Fedora EPEL 7 testing repository.

You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2020-042f5b5af8

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 4 Fedora Update System 2020-08-24 13:34:59 UTC
FEDORA-EPEL-2020-3cbe001af0 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2020-3cbe001af0

Comment 5 Fedora Update System 2020-08-24 13:35:19 UTC
FEDORA-EPEL-2020-60865a6b26 has been submitted as an update to Fedora EPEL 8. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2020-60865a6b26

Comment 6 Fedora Update System 2020-08-24 13:35:40 UTC
FEDORA-2020-a55be98ca8 has been submitted as an update to Fedora 32. https://bodhi.fedoraproject.org/updates/FEDORA-2020-a55be98ca8

Comment 7 Fedora Update System 2020-08-24 13:35:46 UTC
FEDORA-2020-543bedc44c has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2020-543bedc44c

Comment 8 Mattias Ellert 2020-08-24 15:18:42 UTC
This bug should not have been mentioned in the 6.22.02 updates since it is fixed in root-6.22.00-5.el7 and only affected EPEL 7. I have removed the bad references in Bodhi.

Comment 9 Fedora Update System 2020-08-25 00:36:27 UTC
FEDORA-EPEL-2020-042f5b5af8 has been pushed to the Fedora EPEL 7 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.