Bug 186801 - djvu images abort firefox on x86_64 FC5 system
djvu images abort firefox on x86_64 FC5 system
Product: Fedora
Classification: Fedora
Component: djvulibre (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthias Saou
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2006-03-26 11:44 EST by Graham Campbell
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-08-19 11:18:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Log for a complete build of djvulibre-3.5.18 on Dell D820 (230.90 KB, text/plain)
2007-02-13 07:41 EST, Emmanuel Kowalski
no flags Details
Output of rpm -q --requires djvulibre (766 bytes, text/plain)
2007-02-13 07:42 EST, Emmanuel Kowalski
no flags Details

  None (edit)
Description Graham Campbell 2006-03-26 11:44:54 EST
Description of problem:
Plugin aborts firefox on x86_64

Version-Release number of selected component (if applicable):
#uname -r

How reproducible:
Display a Web page with embedded djvu images

Steps to Reproduce:
0. Run FC5 on an x86_64 system
1.go to http://www.teletrade.com/coins/
2.select any of the lots under Thumbnail Images
3.Watch firefox disappear without any messages
Actual results:
Aborted firefox

Expected results:
Web page displayed with djvu images

Additional info:
Comment 1 Graham Campbell 2006-03-26 12:09:53 EST
Just found out that firefox aborts with status code 139
Comment 2 Matthias Saou 2006-07-03 04:26:14 EDT
Sorry for the huge delay in responding, but could you please try the 3.5.17
packages that should appear real shortly and confirm if the problem still happens?
Comment 3 Graham Campbell 2006-07-04 10:13:07 EDT
I uninstalled and reinstalled the djvulibre package. I get different results
from mozilla and firefox.
[gc@orion ~]$ uname 
Linux orion 2.6.17-1.2139_FC5 #1 SMP Fri Jun 23 12:40:11 EDT 2006 x86_64 x86_64
x86_64 GNU/Linux
[gc@orion ~]$ rpm -q djvulibre mozilla firefox
Mozilla - Plugin shown in "about:plugins". Aborts with segfault when I display a
page with embedded image (e.g. from teletrade.com/coins)
Firefox - No plugin shown, brings up an external viewer (djview) when a page is
Comment 4 Matthias Saou 2007-02-05 07:54:10 EST
I've just pushed a new build of 3.5.18 for Fedora development (to be 7). Can you
easily test that? Do you want me to put some testing packages for FC6 x86_64

I've quickly tested 3.5.18 on an x86_64 FC6 machine, but unfortunately I'm
running an i386 firefox. I installed seamonkey, but the plugin doesn't show
up... weird, as /usr/lib64/mozilla/plugins is provided, and even a symlink in
/usr/lib64/seamonkey-1.0.7/plugins doesn't make it appear.
Comment 5 Graham Campbell 2007-02-08 09:14:47 EST
Please put the FC6 packages somewhere, I will test. I am trying to learn enough
about xen to be able to run development systems, but it is slow going.
Comment 6 Matthias Saou 2007-02-12 14:31:19 EST
djvulibre 3.5.18 has now been pushed to FC-5 and FC-6, so you can simply update
your system and let me know if the update fixes this issue.
Comment 7 Emmanuel Kowalski 2007-02-13 04:43:10 EST
I have now a similar (same?) problem with djvulibre-3.5.18; this solved
Bug 228193 for me, but now the plugin aborts immediately when viewing a
web page.

On the other hand, compiling the original src.rpm file from djvulibre.org gives 
a viewer which works both in standalone and browsing mode.  So the problem
has to do with the build process.
Comment 8 Matthias Saou 2007-02-13 05:11:11 EST
What about compiling the Fedora .src.rpm on the same system? Does that still
give you the problem?
- If yes, then it's something in the Fedora spec file, possibly the optflags
- If not, then it's something in the Fedora build system and/or build requirements

Can you test this? It will definitely help track down the problem.
Comment 9 Emmanuel Kowalski 2007-02-13 06:08:07 EST
I just checked, and after building the src.rpm from Fedora, it works fine both
in standalone and browsing mode.
Comment 10 Matthias Saou 2007-02-13 06:42:30 EST
Thanks a lot. Then to continue digging, I'd appreciate if you could :
- Attach the complete build output of a locally rebuilt Fedora package :
  rpmbuild ...blablabla... 2>&1 >/tmp/djvulibre.log
- Post the output of "rpm -q --requires djvulibre" for the working package.
Comment 11 Emmanuel Kowalski 2007-02-13 07:41:39 EST
Created attachment 147982 [details]
Log for a complete build of djvulibre-3.5.18 on Dell D820
Comment 12 Emmanuel Kowalski 2007-02-13 07:42:10 EST
Created attachment 147983 [details]
Output of rpm -q --requires djvulibre
Comment 13 Matthias Saou 2007-02-13 08:02:20 EST
So... no differences in the requirements. So far, so good.

But the build logs shows a few differences :
- Fortran is found in your build environment (I doubt it makes any difference)
- libtool is found in your build environment (this might cause some difference)
- Lots of warnings are present during my build, but not during yours (!?)

The warnings differences are strange, since both builds are using the exact same
CFLAGS. I'll continue looking...
Comment 14 Matthias Saou 2007-02-13 08:36:11 EST
I've been able to reproduce the problem and after some testing, here is my
conclusion : Djvulibre isn't multilib capable...
- When I install both x86_64 and i386 packages, the plugin doesn't work
- When I install _only_ the i386 package, the plugin works

Note that I have an i386 firefox installed, although my system is x86_64, in
order to get flash working. From the requirements of your rebuilt package, I
assume you do too.

I don't see any simple solution here, apart from renaming all the binaries from
one of the archs, so that no 32bit binaries get overwritten when both archs are
installed, then modifying the plugin to call the right programs... any better ideas?

For now, the workaround would be to install _only_ the package from the arch you
require, and not _both_. Can you let me know if it works for you?
Comment 15 Emmanuel Kowalski 2007-02-13 09:09:39 EST
Actually my laptop is not x86_64 (Core Duo, not Core 2 Duo).

Curiously, I've just tried again the updated rpm (downloaded from the extras web
site, and also re-installed via yum), and this time everything worked fine.
So in my case there is no problem left, just a strange situation.

Maybe the overall yum update this morning picked the wrong package the first
Comment 16 Matthias Saou 2007-06-19 11:43:27 EDT
Can you give the latest 3.5.19-2.fc8 package a try?
Don't mind the fc8 tag, it should install and run fine on Fedora 7. If it works
now, I think I won't go looking any further and close this bug... it's confused
me more than enough already ;-)
Comment 17 Matthias Saou 2007-08-19 11:18:47 EDT
I still haven't been able to reproduce the problem with the latest package, so
I'll close as WORKSFORME. Please reopen the bug if you manage to still see it.

Note You need to log in before you can comment on or make changes to this bug.