Bug 186804 - Regression: evince is slower and renders PDF worse than on FC4
Regression: evince is slower and renders PDF worse than on FC4
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: poppler (Show other bugs)
5
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Kristian Høgsberg
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-26 12:44 EST by Emmanuel Kowalski
Modified: 2008-03-12 10:10 EDT (History)
2 users (show)

See Also:
Fixed In Version: poppler-0.5.4-2.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-12 10:10:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot with the same page rendered with evince and xpdf. (270.68 KB, image/png)
2006-03-26 12:44 EST, Emmanuel Kowalski
no flags Details

  None (edit)
Description Emmanuel Kowalski 2006-03-26 12:44:28 EST
Description of problem:


Version-Release number of selected component (if applicable):
evince-0.5.1-3
poppler-0.5.1-2

How reproducible:
For certain files only (with non-standard fonts?)

Steps to Reproduce:
1. Open certain PDF files (in my case, a 544 page book) with evince on FC5
2. Change the page number (e.g. to 200)
3. Change the zoom level
  
Actual results:
Changing to the page is slow, and the page renders badly, both
compared with evince 0.4.0 on FC4 (same computer).
Moreover, both xpdf, kpdf (and acroread) do the rendering faster and better
on FC5 (see below PNG screenshots with xpdf and evince).
Changing the zoom level has the effect of changing the page number(!).

Expected results:
The speed and quality should be at least as good as on FC4. The page number
should not change when altering the zoom level.

Additional info:
Below is attached a screenshot with the same page with xpdf and evince to 
illustrate the difference in rendering quality.

This does not happen with most PDFs. The one used is characterized by some 
non-standard fonts (Garamond), and many symbols. 

Another large PDF file (610 pages) with standard TeX fonts is treated much 
as before with FC4.
Comment 1 Emmanuel Kowalski 2006-03-26 12:44:28 EST
Created attachment 126775 [details]
Screenshot with the same page rendered with evince and xpdf.
Comment 2 Emmanuel Kowalski 2006-03-30 10:08:38 EST
I have confirmed that this is rather a poppler issue: rebuilding the FC4
version of evince with poppler-0.5.1-2 of FC5, the rendering is as slow as
with evince-0.5.1-2.

Comment 3 Emmanuel Kowalski 2006-10-25 08:36:58 EDT
I just upgraded to FC6, and the regression disappears: evince now once more
displays the files I tried with the same quality as it did in FC4.

$ rpm -q evince poppler
evince-0.6.0-3.fc6
poppler-0.5.4-2.fc6
Comment 4 Edgar Hoch 2007-01-22 05:39:02 EST
I think, if the problem is resolved, the bug should be closed and not leaved in
new state.
Comment 5 Peter van Egdom 2008-03-12 10:10:21 EDT
Thank you for the bug report. Closing bug as per comment #3.

Note You need to log in before you can comment on or make changes to this bug.