Bug 186815 - Upgrade garbled quoted space character in /etc/fstab
Upgrade garbled quoted space character in /etc/fstab
Product: Fedora
Classification: Fedora
Component: hal (Show other bugs)
powerpc Linux
medium Severity medium
: ---
: ---
Assigned To: David Zeuthen
Depends On:
  Show dependency treegraph
Reported: 2006-03-26 15:17 EST by Derek Poon
Modified: 2013-03-05 22:45 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-05-06 11:39:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Derek Poon 2006-03-26 15:17:31 EST
Description of problem:

While running Fedora Core 4, I had an entry in /etc/fstab like this:
  /dev/hda3   /Macintosh\040HD    hfsplus   ro   0 0
The \040 represents a space character, according to fstab(5).

After I ran the installer to upgrade to Fedora Core 5, that line turned into
  /dev/hda3   /Macintosh040HD     hfsplus   ro   0 0

How reproducible:
I haven't tried reproducing it.

Additional info:
After manually putting the backslash back into /etc/fstab, my mount point works
again, which means that glibc and mount are working fine.  The problem is in the
installer or some process that it spawns.
Comment 1 Derek Poon 2006-03-26 15:43:23 EST
The upgrade left a file /fstab.replace that also has the backslash removed.  I
don't know why that temporary file didn't get removed.
Comment 2 John (J5) Palmieri 2006-03-27 13:44:13 EST

The issue will only happen once because it is triggered if you have a HAL
version < some older version.  It will be fixed for upgrades.
Comment 3 Bug Zapper 2008-04-03 22:16:17 EDT
Fedora apologizes that these issues have not been resolved yet. We're
sorry it's taken so long for your bug to be properly triaged and acted
on. We appreciate the time you took to report this issue and want to
make sure no important bugs slip through the cracks.

If you're currently running a version of Fedora Core between 1 and 6,
please note that Fedora no longer maintains these releases. We strongly
encourage you to upgrade to a current Fedora release. In order to
refocus our efforts as a project we are flagging all of the open bugs
for releases which are no longer maintained and closing them.

If this bug is still open against Fedora Core 1 through 6, thirty days
from now, it will be closed 'WONTFIX'. If you can reporduce this bug in
the latest Fedora version, please change to the respective version. If
you are unable to do this, please add a comment to this bug requesting
the change.

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we are following is outlined here:

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.

And if you'd like to join the bug triage team to help make things
better, check out http://fedoraproject.org/wiki/BugZappers
Comment 4 Bug Zapper 2008-05-06 11:39:06 EDT
This bug is open for a Fedora version that is no longer maintained and
will not be fixed by Fedora. Therefore we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen thus bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.