Note: This bug is displayed in read-only format because the product is no longer active in Red Hat Bugzilla.

Bug 1868280

Summary: Found `Could not create ServiceMonitor object` when EO/CLO start.
Product: OpenShift Container Platform Reporter: Qiaoling Tang <qitang>
Component: LoggingAssignee: ewolinet
Status: CLOSED ERRATA QA Contact: Qiaoling Tang <qitang>
Severity: high Docs Contact:
Priority: high    
Version: 4.6CC: aconway, aos-bugs, ewolinet
Target Milestone: ---   
Target Release: 4.6.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard: logging-exploration
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2020-10-27 15:09:55 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:

Description Qiaoling Tang 2020-08-12 08:19:03 UTC
Description of problem:
Deploy EO, check the logs, found below error:

{"level":"info","ts":1597218564.9376895,"logger":"cmd","msg":"Could not create ServiceMonitor object","error":"servicemonitors.monitoring.coreos.com \"elasticsearch-operator-metrics\" is forbidden: cannot set blockOwnerDeletion if an ownerReference refers to a resource you can't set finalizers on: , <nil>"}

Couldn't find this servicemonitor/elasticsearch-operator-metrics in the openshift-operators-redhat namespace after the EO is started.

Version-Release number of selected component (if applicable):
elasticsearch-operator.4.6.0-202008110953.p0 

How reproducible:
Always

Steps to Reproduce:
1. deploy EO
2. check EO logs
3.

Actual results:


Expected results:
Should not have this failure log in EO.

Additional info:

Comment 1 Qiaoling Tang 2020-08-12 08:24:45 UTC
I found a similar error in the CLO:

{"level":"info","ts":1597218564.8095691,"logger":"cmd","msg":"Could not create ServiceMonitor object","error":"servicemonitors.monitoring.coreos.com \"cluster-logging-operator-metrics\" is forbidden: cannot set blockOwnerDeletion if an ownerReference refers to a resource you can't set finalizers on: , <nil>"}
{"level":"info","ts":1597218564.8095956,"logger":"cmd","msg":"Starting the Cmd."}

Comment 4 Qiaoling Tang 2020-08-24 08:34:00 UTC
Verified with clusterlogging.4.6.0-202008202200.p0 and elasticsearch-operator.4.6.0-202008202200.p0

Comment 6 errata-xmlrpc 2020-10-27 15:09:55 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6.1 extras update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4198