Bug 1868314 - Scheduler is not always reporting all failed reasons
Summary: Scheduler is not always reporting all failed reasons
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: kube-scheduler
Version: 4.5
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.5.z
Assignee: Jan Chaloupka
QA Contact: zhou ying
URL:
Whiteboard:
Depends On: 1869542
Blocks: 1763662
TreeView+ depends on / blocked
 
Reported: 2020-08-12 09:45 UTC by Jan Chaloupka
Modified: 2020-09-08 10:55 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-09-08 10:54:46 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift origin pull 25407 None closed Bug 1868314: UPSTREAM: 93355: Fix scheduler issue with nodetree additions 2020-09-24 09:44:22 UTC
Red Hat Product Errata RHBA-2020:3510 None None None 2020-09-08 10:55:29 UTC

Description Jan Chaloupka 2020-08-12 09:45:33 UTC
I0804 01:22:21.534445       1 factory.go:462] Unable to schedule e2e-provisioning-9050/pod-subpath-test-inlinevolume-b9ts: no fit: 0/6 nodes are available: 5 node(s) didn't match node selector.; waiting
I0804 01:22:21.552115       1 factory.go:462] Unable to schedule e2e-provisioning-9050/pod-subpath-test-inlinevolume-b9ts: no fit: 0/6 nodes are available: 5 node(s) didn't match node selector.; waiting

6 nodes but only 5 reasons reported

Upstream fix: https://github.com/kubernetes/kubernetes/pull/93355

Comment 2 Jan Chaloupka 2020-08-12 11:23:39 UTC
The upstream fix is not yet in openshift/kubernetes:release-4.6 branch which is currently rebased to 1.19 rc2.
It is part of 1.19 rc3. Waiting for the next rebase until it gets to 4.6. Once done, we can clone this to 4.5 and fix it there.

Comment 3 Jan Chaloupka 2020-08-12 11:25:44 UTC
4.5 PR https://github.com/openshift/origin/pull/25407

Comment 4 Jan Chaloupka 2020-08-24 14:23:47 UTC
Rama, no need to test this issue. It's mainly for backporting master fix to 4.5 so we can further debug flaking/failing e2e tests.

Comment 7 zhou ying 2020-09-01 07:05:48 UTC
Checked log from : https://search.ci.openshift.org/?search=Unable+to+schedule&maxAge=48h&context=1&type=junit&name=&maxMatches=5&maxBytes=20971520&groupBy=job. 

Can't reproduce the issue now. Will move to verified.

Comment 9 errata-xmlrpc 2020-09-08 10:54:46 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.5.8 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:3510


Note You need to log in before you can comment on or make changes to this bug.