Bug 1868328 - Some resources in "Related Objects" for cluster operator "cloud-credential" have no link to the detail page
Summary: Some resources in "Related Objects" for cluster operator "cloud-credential" h...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.6
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.6.0
Assignee: Jakub Hadvig
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-08-12 10:32 UTC by Yanping Zhang
Modified: 2020-10-27 16:28 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:28:06 UTC
Target Upstream Version:


Attachments (Terms of Use)
relatedobjects (104.46 KB, image/png)
2020-08-12 10:32 UTC, Yanping Zhang
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift cloud-credential-operator pull 233 0 None closed Bug 1868328: Fix cases in cloud-credential's related objects 2020-08-24 08:00:45 UTC
Github openshift cloud-credential-operator pull 235 0 None closed Bug 1868328: CredentialsRequest should be plural 2020-08-24 08:00:45 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:28:21 UTC

Description Yanping Zhang 2020-08-12 10:32:53 UTC
Created attachment 1711172 [details]
relatedobjects

Description of problem:
Go to "Related Objects" tab of cluster operator "cloud-credential" page, check all resources, some resource names have no link.

Version-Release number of selected component (if applicable):
4.6.0-0.nightly-2020-08-11-165822

How reproducible:
Always

Steps to Reproduce:
1.Go to "Related Objects" tab of cluster operator "cloud-credential" page, check all resources.
2.
3.

Actual results:
1. Some resources have no link with name, eg: all resources "CredentialsRequest" have no link with name.

Expected results:
1. The name should have link to that resouce's detail page.

Additional info:

Comment 3 Yanping Zhang 2020-08-13 03:15:53 UTC
Checked on OCP 4.6 with payload 4.6.0-0.nightly-2020-08-12-230932.
Go to "Related Objects" tab of cluster operator "cloud-credential" page, check all resources. "cloudcredentials","clusterroles" have links now.
But all "credentialsrequest" resources still have no link.

Comment 5 Yanping Zhang 2020-08-18 02:45:19 UTC
Checked on  4.6 cluster with payload 4.6.0-0.nightly-2020-08-17-212631
Now all related objects for cluster operator "cloud-credential" page have right link now.
The bug is fixed, so move it to Verified.

Comment 7 errata-xmlrpc 2020-10-27 16:28:06 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.