Bug 1868394 - Pending changes alert shows on VM's details when there is an implicit boot-order
Summary: Pending changes alert shows on VM's details when there is an implicit boot-order
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Kubevirt Plugin
Version: 4.5
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: 4.6.0
Assignee: Ido Rosenzwig
QA Contact: Guohua Ouyang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-08-12 14:14 UTC by Ido Rosenzwig
Modified: 2020-10-27 16:28 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:28:06 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 6315 0 None closed Bug 1868394: Fix boot-order change alert when VM is running 2020-09-29 05:48:02 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:28:24 UTC

Description Ido Rosenzwig 2020-08-12 14:14:23 UTC
Description of problem:
Pending changes alert shows on VM's details when there is an implicit boot-order

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. create a VM (via yaml)
2. remove all disks and nics in the boot order (in the details tab)
3. start the VM

Actual results:
an alert is presented.

Expected results:
no alert should be presented - only when the disks order changed in the YAML

Additional info:

Comment 3 Guohua Ouyang 2020-09-04 03:31:47 UTC
remove the boot device and start the vm, there is no alert message shows.

Comment 5 errata-xmlrpc 2020-10-27 16:28:06 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.