Bug 186841 - Kernel ATA Errors Prevent Usage After Install :(
Kernel ATA Errors Prevent Usage After Install :(
Status: CLOSED DUPLICATE of bug 186839
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
5
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
: Regression
: 186840 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-26 19:46 EST by Peter Gordon
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-26 20:57:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Peter Gordon 2006-03-26 19:46:29 EST
Description of problem:
After installing FC5 anew (not a upgrade from FC4), it boots up nicely but after
a interval of about a few minutes after logging in and playing with Pirut,
everything seems to slow down immensely, and after a few seconds the machine
locks up (I am able to type in things, move the mouse, and click things, but
with no response from both within X11 and in the terminal). Booting from
Knoppix, I checked my logs and found many of the follow error littered at short
intervals (each a few minutes apart):

ata1: command 0x35 timeout, stat 0x50 host_stat

A Google search turned up a thread on the LKML about LibPATA code issues in
2.6.15.4, which resulted in the poster resolved it by finding out that his disk
was dying. Fortunately, this does not seem to be the case for me, as this disk
(Western Digital Raptor, model WD740GD-41FLC2) works just fine in Core 4 after a
reinstallation and full update. This is on an ABIT VT7 motherboard (VIA
PT880-8237 chipset with a VT6420 SATA RAID Controller; not using RAID).



Version-Release number of selected component (if applicable):
kernel-2.6.15-1.2054_FC5

How reproducible:
Every time.

Steps to Reproduce:
1. Install FC5.
2. Reboot.
3. Try to login and do things.
  
Actual results:
The ata1 errors in my kernel logs as mentioned and a general system crash, as
outlined above.

Expected results:
Expected FC5 to work well on it, as FC4 does.

Additional info:
I re-installed FC4 and am using that for the time being. The following is the
relevant part of my kernel log from FC4:

SCSI subsystem initialized
libata version 1.20 loaded.
sata_via 0000:00:0f.0: version 1.1
ACPI: PCI Interrupt 0000:00:0f.0[B] -> Link [LNKB] -> GSI 11 (level, low) -> IRQ 11
sata_via 0000:00:0f.0: routed to hard irq line 11
ata1: SATA max UDMA/133 cmd 0xB400 ctl 0xB802 bmdma 0xC400 irq 11
ata1: SATA link up 1.5 Gbps (SStatus 113)
ata1: dev 0 cfg 49:2f00 82:74eb 83:7f63 84:4003 85:74e9 86:3c43 87:4003 88:407f
ata1: dev 0 ATA-6, max UDMA/133, 145226112 sectors: LBA48
ata1: dev 0 configured for UDMA/133
scsi0 : sata_via
  Vendor: ATA       Model: WDC WD740GD-41FL  Rev: 31.0
  Type:   Direct-Access                      ANSI SCSI revision: 05
SCSI device sda: 145226112 512-byte hdwr sectors (74356 MB)
SCSI device sda: drive cache: write back
SCSI device sda: 145226112 512-byte hdwr sectors (74356 MB)
SCSI device sda: drive cache: write back
 sda: sda1 sda2 sda3 sda4 < sda5 sda6 sda7 sda8 >
sd 0:0:0:0: Attached scsi disk sda
Comment 1 Peter Gordon 2006-03-26 19:48:52 EST
*** Bug 186840 has been marked as a duplicate of this bug. ***
Comment 2 Peter Gordon 2006-03-26 19:50:36 EST
The error message ends in "host_stat 0x4" actually. I forgot to add that in
there, sorry. :O
Comment 3 Rahul Sundaram 2006-03-26 20:57:31 EST
Thank you for the bug report. This particular bug has already been reported
into our bug tracking system, but please feel free to report any further
bugs you find.

*** This bug has been marked as a duplicate of 186839 ***

Note You need to log in before you can comment on or make changes to this bug.