Bug 1868448 - 4.6 vsphere IPI CI: Worker nodes are not being created
Summary: 4.6 vsphere IPI CI: Worker nodes are not being created
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Cloud Compute
Version: 4.6
Hardware: Unspecified
OS: Unspecified
high
urgent
Target Milestone: ---
: 4.6.0
Assignee: Alexander Demicev
QA Contact: Milind Yadav
URL:
Whiteboard:
Depends On: 1859230
Blocks: 1865743
TreeView+ depends on / blocked
 
Reported: 2020-08-12 17:59 UTC by Abhinav Dahiya
Modified: 2020-10-27 16:28 UTC (History)
18 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1859230
Environment:
Last Closed: 2020-10-27 16:28:06 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:28:24 UTC

Comment 6 Xingxing Xia 2020-08-19 03:05:19 UTC
After QE discussion, though comment 2 and comment 4 seem to have different cause, though they indicate almost same errors as original bug. Will dig again.
So please ignore comment 2 and 4. Restoring original bug title ...

Comment 7 Johnny Liu 2020-08-19 05:13:33 UTC
Though 120G minimal disk size is official recommendation, for testing purpose, actually usually QE did not need so big size, because QE's vsphere cluster only has limit storage, it is possible to make the minimal disk size checking not mandatory, but use a warning message to instead of it?

Comment 8 Xingxing Xia 2020-08-19 05:56:12 UTC
Continuing comment 6: after more digging, my AWS envs' failure symptom is as same as bug 1862957#c7 ~ 1862957#c9, the cause is as same as bug 1862957, so my AWS envs failure will be tracked by that bug.

Comment 9 jima 2020-08-20 04:39:15 UTC
I checked that disk checking is introduced from PR: https://github.com/openshift/machine-api-operator/commit/5229694cbb14e3cd79a6a4dc0069fa2129920a34.
It seems that other platform disk limitation checking does not use the default value of official recommendation. Take GCP for example, the checking is 16GB < GCP disksize < 65536GB, the official recommendation value is 128GB.
As Jianlin in Comment 7 described, QE's vsphere cluster has limit storage, if setting 120G disk for each vm in one cluster on QE vsphere env, only 1 cluster can be setup at the same time. It has serious impact for QE to test on vsphere platform.
So is it possible to check vsphere disksize like than on GCP? Or let disksize checking not mandatory on vsphere platform?

Comment 11 Alberto 2020-09-08 10:28:02 UTC
this should prevent this from happening https://github.com/openshift/release/pull/11534

Comment 15 Milind Yadav 2020-09-18 04:25:28 UTC
Based on understanding that same change to size works for QA flexi envs templates moving this to VERIFIED

Comment 17 errata-xmlrpc 2020-10-27 16:28:06 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.