Bug 186846 - Wine doesn't work.
Wine doesn't work.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: wine (Show other bugs)
5
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Andreas Bierfert
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-26 21:02 EST by tim
Modified: 2007-11-30 17:11 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-17 03:29:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Strace output from wine (24.52 KB, text/plain)
2006-03-27 11:12 EST, tim
no flags Details
winecfg strace output (598.98 KB, application/x-bzip)
2006-07-05 18:14 EDT, Ed Marshall
no flags Details
strace of wineprefixcreate (38.49 KB, text/plain)
2006-08-24 04:41 EDT, Joachim Selke
no flags Details
strace of wineprefixcreate (37.89 KB, text/plain)
2006-08-24 04:50 EDT, Joachim Selke
no flags Details
strace outputs from 0.9.22 and 0.9.23, for comparison (99.09 KB, application/x-gzip)
2006-10-21 05:39 EDT, Alex W. Jackson
no flags Details

  None (edit)
Description tim 2006-03-26 21:02:43 EST
Description of problem: After installing Wine through Yum and trying to run it,
after saying, "wine: creating configuration directory" it just stops. Nothing
more is output and the prompt just stays there. It does create a wine directory,
wine-<random letters> and creates some folders/files inside this directory, but
if one tries to run wine after stopping the previous process it just tries to
create another directory.


Version-Release number of selected component (if applicable): 0.9.10-2.fc5


How reproducible: Happens every time, even after uninstalling/reinstalling
through yum or rpm commands.


Steps to Reproduce:
1. Yum remove wine
2. Yum install wine
3. wine
  
Actual results: [tim@localhost ~]$ wine
wine: creating configuration directory '/home/tim/.wine'...


Expected results: To have wine create the directory and allow me to run Windows
programs.


Additional info: I've tried both 0.9.10-1 and 0.9.10-2 rpm's in the extra's
repository and the same thing happens with both rpm's.
Comment 1 Andreas Bierfert 2006-03-27 06:09:24 EST
Hm this is indeed strange...

testing here works fine. Could you provide me with an strace maybe?
Comment 2 tim 2006-03-27 11:12:01 EST
Created attachment 126830 [details]
Strace output from wine

I was unable to copy the first part of the output as it was too far up in
console, but at the bottom of this text file is where it stops every time (of
course each time having a different waitpid) and after hitting ctrl+c to quit
the operation, wineprefixcreat, wine-preloader, and wineserver continue to run.
i can kill all but the preloader with the kill command, but for some reason the
preloader stays running. if i try it multiple times, i get multiple
wine-preloader's.
Comment 3 Ed Marshall 2006-07-05 18:14:05 EDT
Created attachment 131966 [details]
winecfg strace output

I get a problem with wine as well. Fresh install running 0.9.16-1.fc5 from
extras, I get the following:

[esm@localhost ~]$ winecfg
wine: creating configuration directory '/home/esm/.wine'...
wine: Unhandled page fault on read access to 0x003c002f at address 0x20195c97
(thread 0009), starting debugger...

A window pops up at that point, with the message:

Unhandled page fault on read access to 0x003c002f at address 0x20195c97. Do you
wish to debug it?

Clicking "No" results in the terminal output:

wine: wineprefixcreate failed while creating '/home/esm/.wine'.

Clicking "Yes" gives me:

wine client error:9: write: Bad file descriptor
wine client error:9: err:seh:setup_exception stack overflow 240 bytes in thread
0009 eip 47e31025 esp 7fb90f10 stack 0x7fb91000-0x7fca0000
wine: '/home/esm/.wine' created successfully.

...and then the winecfg window pops up. The "Bad file descriptor" message
repeats an enormous number of times.

I've attached an strace for this; however, I received the following output
during the capture:

ptrace: umoven: Input/output error
ptrace: umoven: Input/output error
ptrace: umoven: Input/output error
wine: creating configuration directory '/home/esm/.wine'...
ptrace: umoven: Input/output error
ptrace: umoven: Input/output error
ptrace: umoven: Input/output error
wine: Unhandled page fault on read access to 0x003c002f at address 0x56bbcc97
(thread 0009), starting debugger...
wine: wineprefixcreate failed while creating '/home/esm/.wine'.
wineserver: could not save registry branch to /home/esm/.wine-wX9oXb/system.reg
: No such file or directory
wineserver: could not save registry branch to
/home/esm/.wine-wX9oXb/userdef.reg : No such file or directory
wineserver: could not save registry branch to /home/esm/.wine-wX9oXb/user.reg :
No such file or directory
Comment 4 Ed Marshall 2006-07-05 18:16:08 EDT
I should probably note my hardware: Linux localhost.localdomain
2.6.17-1.2139_FC5 #1 Fri Jun 23 12:40:16 EDT 2006 i686 i686 i386 GNU/Linux

It's a Lenovo/IBM ThinkPad T43p.
Comment 5 Andreas Bierfert 2006-07-06 05:23:15 EDT
Hm, don't know ... will have to spent some more time with this. Maybe try to
move your ~/.wine directory out of the way and run it again...
Comment 6 Ed Marshall 2006-07-06 08:34:06 EDT
Actually, I already tried that; what originally alerted me to the problem was
the fact that winetools would fail when setting up the base configuration. Turns
out that it was failing at the winecfg invokation. So, I moved my .wine
directory out of the way, and started working with winecfg directly, and that's
the behavior I saw.
Comment 7 Joachim Selke 2006-08-23 12:42:15 EDT
I have the same problem here. When running wineprefixcreate I just get the
message "fixme:ole:ITypeInfo_fnRelease destroy child objects" but it never
finishes. Can I help with providing some information to fix this bug?
Comment 8 Andreas Bierfert 2006-08-24 02:32:45 EDT
Still works like a charm here. Could you please tell me exactly what wine
version you are running, what arch, and which wine packages you have installed...
Comment 9 Joachim Selke 2006-08-24 03:14:58 EDT
I have the following packages installed (via "yum install wine"):
wine
wine-capi
wine-cms
wine-core
wine-esd
wine-jack
wine-ldap
wine-nas
wine-tools
wine-twain

All these packages have version 0.9.19-1.fc5.

I am running an x86_64 system.

What else do you need?
Comment 10 Joachim Selke 2006-08-24 04:41:37 EDT
Created attachment 134790 [details]
strace of wineprefixcreate
Comment 11 Joachim Selke 2006-08-24 04:49:41 EDT
Comment on attachment 134790 [details]
strace of wineprefixcreate

This strace erroneously contains my kill of the wineprefixcreate process. I
will upload a new one.
Comment 12 Joachim Selke 2006-08-24 04:50:41 EDT
Created attachment 134796 [details]
strace of wineprefixcreate
Comment 13 Joachim Selke 2006-08-26 16:19:05 EDT
Hm, this is strange. If I wait for about 20 minutes the wineprefixcreate task
finishes:

[selke@jselke ~]$ time wineprefixcreate
fixme:ole:ITypeInfo_fnRelease destroy child objects
/home/selke/.wine updated successfully.

real    18m58.531s
user    0m0.748s
sys     0m1.000s

Seems like it is running into some timeout. How can I get debug information on this?
Comment 14 Joachim Selke 2006-08-27 07:22:46 EDT
The strange behavior of wine on my system might be related to glibc. As
workaround for some bug in cdrecord I updated glibc to the current development
version yesterday. Now wineprefixcreate finishes much faster:

[selke@jselke ~]$ time wineprefixcreate
fixme:ole:ITypeInfo_fnRelease destroy child objects
/home/selke/.wine updated successfully.

real    0m52.870s
user    0m13.681s
sys     0m0.904s
Comment 15 Joachim Selke 2006-08-27 13:19:53 EDT
Now I found the real cause for the long running time of the wineprefixcreate
task. It is not related to glibc but to CUPS. During wineprefixcreate a
connection to the CUPS web interface is established.

If I have no printers configured and CUPS running wineprefixcreate works as
supposed. Same is when I have printers configured and CUPS stopped. But if I
configured some printers using system-config-printer and have CUPS running the
problem occurs. I don't know whether it depends on the printer models but
neither for an HP Laserjet 1320 nor an HP Laserjet 2100M it works.

But this seems to be a known bug:
http://www.winehq.com/pipermail/wine-users/2006-May/thread.html#21407

What should I do?
Comment 16 Joachim Selke 2006-09-15 09:58:44 EDT
I reinstalled Fedora and now my problem with Wine is gone. Strange ...
Comment 17 Andreas Bierfert 2006-09-17 03:29:35 EDT
Maybe it was a problem with your ~/.wine directory... I will close this for now
... if there are other problems like this I can always reopen...
Comment 18 Alex W. Jackson 2006-10-20 03:04:51 EDT
This is happening to me with the wine 0.9.23 package that was added to Extras
the other day.  After deleting my .wine directory, I run winecfg and it displays
the following messages:

wine: creating configuration directory '/home/awj/.wine'...
Failed to open the service control manager.
fixme:ole:ITypeInfo_fnRelease destroy child objects

and then it just hangs.  0.9.22 worked fine.
Comment 19 Alex W. Jackson 2006-10-20 13:59:12 EDT
Confirmation:  I uninstalled 0.9.23, reinstalled 0.9.22, and it works again,
with or without a ~/.wine directory present.  When I upgrade to 0.9.23, running
winecfg or any other wine application results in a hang, whether or not ~/.wine
is present.  If .wine is present and I run winecfg, it gets as far as the
titlebar and frame of the Wine Configuration window appearing, but with nothing
inside them, and the half-drawn window is totally unresponsive.
Comment 20 Alex W. Jackson 2006-10-21 05:39:23 EDT
Created attachment 139052 [details]
strace outputs from 0.9.22 and 0.9.23, for comparison

Outputs of strace -ff -o running winecfg from wine-core-0.9.22-1.fc5 (which
works) and wine-core-0.9.23-1.fc5 (which doesn't work, it just hangs until I
hit ctrl-c)

Note You need to log in before you can comment on or make changes to this bug.