Bug 1868618 - Cant install nagios-plugins-mysql.x86_64 if using MariaDB 10.3
Summary: Cant install nagios-plugins-mysql.x86_64 if using MariaDB 10.3
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: nagios-plugins
Version: epel8
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Guido Aulisi
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-08-13 10:07 UTC by jeffrey Smith
Modified: 2021-04-06 01:29 UTC (History)
5 users (show)

Fixed In Version: nagios-plugins-2.3.3-5.el8
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-04-06 01:29:17 UTC
Type: Bug


Attachments (Terms of Use)

Description jeffrey Smith 2020-08-13 10:07:25 UTC
Description of problem:

dnf install nagios-plugins-mysql fails. It appears to require mysql8 libs to be installed but I already have mariaDB 10.3 installed which causes the install to fail.


Version-Release number of selected component (if applicable):

nagios-plugins-mysql-2.3.3-4.el8.x86_64.rpm


How reproducible:


Steps to Reproduce:
1. dnf install nagios-plugins-mysql fails.


Actual results:

[root@XXXXX ~]# dnf install nagios-plugins-mysql
Last metadata expiration check: 1:16:01 ago on Thu 13 Aug 2020 08:16:05 UTC.
yDependencies resolved.
=============================================================================================================================================================================================================================================
 Package                                                    Architecture                                 Version                                                                       Repository                                       Size
=============================================================================================================================================================================================================================================
Installing:
 nagios-plugins-mysql                                       x86_64                                       2.3.3-4.el8                                                                   epel                                             56 k
Installing dependencies:
 mysql-common                                               x86_64                                       8.0.17-3.module_el8.0.0+181+899d6349                                          AppStream                                       143 k
 mysql-libs                                                 x86_64                                       8.0.17-3.module_el8.0.0+181+899d6349                                          AppStream                                       1.2 M
Enabling module streams:
 mysql                                                                                                   8.0

Transaction Summary
=============================================================================================================================================================================================================================================
Install  3 Packages

Total size: 1.4 M
Installed size: 7.8 M
Is this ok [y/N]: y
Is this ok [y/N]: y
Downloading Packages:
[SKIPPED] mysql-common-8.0.17-3.module_el8.0.0+181+899d6349.x86_64.rpm: Already downloaded
[SKIPPED] mysql-libs-8.0.17-3.module_el8.0.0+181+899d6349.x86_64.rpm: Already downloaded
[SKIPPED] nagios-plugins-mysql-2.3.3-4.el8.x86_64.rpm: Already downloaded
Running transaction check
Transaction check succeeded.
Running transaction test
The downloaded packages were saved in cache until the next successful transaction.
You can remove cached packages by executing 'dnf clean packages'.
Error: Transaction test error:
  file /usr/share/mysql/charsets/Index.xml from install of mysql-common-8.0.17-3.module_el8.0.0+181+899d6349.x86_64 conflicts with file from package mariadb-common-3:10.3.17-1.module_el8.1.0+257+48736ea6.x86_64
  file /usr/share/mysql/charsets/armscii8.xml from install of mysql-common-8.0.17-3.module_el8.0.0+181+899d6349.x86_64 conflicts with file from package mariadb-common-3:10.3.17-1.module_el8.1.0+257+48736ea6.x86_64
  file /usr/share/mysql/charsets/ascii.xml from install of mysql-common-8.0.17-3.module_el8.0.0+181+899d6349.x86_64 conflicts with file from package mariadb-common-3:10.3.17-1.module_el8.1.0+257+48736ea6.x86_64
  file /usr/share/mysql/charsets/cp1250.xml from install of mysql-common-8.0.17-3.module_el8.0.0+181+899d6349.x86_64 conflicts with file from package mariadb-common-3:10.3.17-1.module_el8.1.0+257+48736ea6.x86_64
  file /usr/share/mysql/charsets/cp1251.xml from install of mysql-common-8.0.17-3.module_el8.0.0+181+899d6349.x86_64 conflicts with file from package mariadb-common-3:10.3.17-1.module_el8.1.0+257+48736ea6.x86_64
  file /usr/share/mysql/charsets/cp1256.xml from install of mysql-common-8.0.17-3.module_el8.0.0+181+899d6349.x86_64 conflicts with file from package mariadb-common-3:10.3.17-1.module_el8.1.0+257+48736ea6.x86_64
  file /usr/share/mysql/charsets/cp1257.xml from install of mysql-common-8.0.17-3.module_el8.0.0+181+899d6349.x86_64 conflicts with file from package mariadb-common-3:10.3.17-1.module_el8.1.0+257+48736ea6.x86_64
  file /usr/share/mysql/charsets/cp850.xml from install of mysql-common-8.0.17-3.module_el8.0.0+181+899d6349.x86_64 conflicts with file from package mariadb-common-3:10.3.17-1.module_el8.1.0+257+48736ea6.x86_64
  file /usr/share/mysql/charsets/cp852.xml from install of mysql-common-8.0.17-3.module_el8.0.0+181+899d6349.x86_64 conflicts with file from package mariadb-common-3:10.3.17-1.module_el8.1.0+257+48736ea6.x86_64
  file /usr/share/mysql/charsets/cp866.xml from install of mysql-common-8.0.17-3.module_el8.0.0+181+899d6349.x86_64 conflicts with file from package mariadb-common-3:10.3.17-1.module_el8.1.0+257+48736ea6.x86_64
  file /usr/share/mysql/charsets/dec8.xml from install of mysql-common-8.0.17-3.module_el8.0.0+181+899d6349.x86_64 conflicts with file from package mariadb-common-3:10.3.17-1.module_el8.1.0+257+48736ea6.x86_64
  file /usr/share/mysql/charsets/geostd8.xml from install of mysql-common-8.0.17-3.module_el8.0.0+181+899d6349.x86_64 conflicts with file from package mariadb-common-3:10.3.17-1.module_el8.1.0+257+48736ea6.x86_64
  file /usr/share/mysql/charsets/greek.xml from install of mysql-common-8.0.17-3.module_el8.0.0+181+899d6349.x86_64 conflicts with file from package mariadb-common-3:10.3.17-1.module_el8.1.0+257+48736ea6.x86_64
  file /usr/share/mysql/charsets/hebrew.xml from install of mysql-common-8.0.17-3.module_el8.0.0+181+899d6349.x86_64 conflicts with file from package mariadb-common-3:10.3.17-1.module_el8.1.0+257+48736ea6.x86_64
  file /usr/share/mysql/charsets/hp8.xml from install of mysql-common-8.0.17-3.module_el8.0.0+181+899d6349.x86_64 conflicts with file from package mariadb-common-3:10.3.17-1.module_el8.1.0+257+48736ea6.x86_64
  file /usr/share/mysql/charsets/keybcs2.xml from install of mysql-common-8.0.17-3.module_el8.0.0+181+899d6349.x86_64 conflicts with file from package mariadb-common-3:10.3.17-1.module_el8.1.0+257+48736ea6.x86_64
  file /usr/share/mysql/charsets/koi8r.xml from install of mysql-common-8.0.17-3.module_el8.0.0+181+899d6349.x86_64 conflicts with file from package mariadb-common-3:10.3.17-1.module_el8.1.0+257+48736ea6.x86_64
  file /usr/share/mysql/charsets/koi8u.xml from install of mysql-common-8.0.17-3.module_el8.0.0+181+899d6349.x86_64 conflicts with file from package mariadb-common-3:10.3.17-1.module_el8.1.0+257+48736ea6.x86_64
  file /usr/share/mysql/charsets/latin1.xml from install of mysql-common-8.0.17-3.module_el8.0.0+181+899d6349.x86_64 conflicts with file from package mariadb-common-3:10.3.17-1.module_el8.1.0+257+48736ea6.x86_64
  file /usr/share/mysql/charsets/latin2.xml from install of mysql-common-8.0.17-3.module_el8.0.0+181+899d6349.x86_64 conflicts with file from package mariadb-common-3:10.3.17-1.module_el8.1.0+257+48736ea6.x86_64
  file /usr/share/mysql/charsets/latin5.xml from install of mysql-common-8.0.17-3.module_el8.0.0+181+899d6349.x86_64 conflicts with file from package mariadb-common-3:10.3.17-1.module_el8.1.0+257+48736ea6.x86_64
  file /usr/share/mysql/charsets/latin7.xml from install of mysql-common-8.0.17-3.module_el8.0.0+181+899d6349.x86_64 conflicts with file from package mariadb-common-3:10.3.17-1.module_el8.1.0+257+48736ea6.x86_64
  file /usr/share/mysql/charsets/macce.xml from install of mysql-common-8.0.17-3.module_el8.0.0+181+899d6349.x86_64 conflicts with file from package mariadb-common-3:10.3.17-1.module_el8.1.0+257+48736ea6.x86_64
  file /usr/share/mysql/charsets/macroman.xml from install of mysql-common-8.0.17-3.module_el8.0.0+181+899d6349.x86_64 conflicts with file from package mariadb-common-3:10.3.17-1.module_el8.1.0+257+48736ea6.x86_64
  file /usr/share/mysql/charsets/swe7.xml from install of mysql-common-8.0.17-3.module_el8.0.0+181+899d6349.x86_64 conflicts with file from package mariadb-common-3:10.3.17-1.module_el8.1.0+257+48736ea6.x86_64


Expected results:

It to install the package.

Additional info:

This is on centos machine "CentOS Linux release 8.2.2004 (Core)"

Comment 1 jeffrey Smith 2020-08-13 10:28:28 UTC
So I have another system where this actually worked.

I believe that's because I installed nrpe and the nagios-plugins first and then installed mariadb after. On this systems I have mariadb already installed and want to add nagios-plugin-mysql. 

I also cant install mysql-libs which is what the dependency is.

[root@XXXXXXX packages]# yum install mysql-libs
Last metadata expiration check: 2:07:25 ago on Thu 13 Aug 2020 08:16:05 UTC.
Dependencies resolved.
=========================================================================================================================================
 Package                     Architecture          Version                                                Repository                Size
=========================================================================================================================================
Installing:
 mysql-libs                  x86_64                8.0.17-3.module_el8.0.0+181+899d6349                   AppStream                1.2 M
Installing dependencies:
 mysql-common                x86_64                8.0.17-3.module_el8.0.0+181+899d6349                   AppStream                143 k
Enabling module streams:
 mysql                                             8.0

Transaction Summary
=========================================================================================================================================
Install  2 Packages

Total size: 1.4 M
Installed size: 7.7 M
Is this ok [y/N]: y
Downloading Packages:
[SKIPPED] mysql-common-8.0.17-3.module_el8.0.0+181+899d6349.x86_64.rpm: Already downloaded
[SKIPPED] mysql-libs-8.0.17-3.module_el8.0.0+181+899d6349.x86_64.rpm: Already downloaded
Running transaction check
Transaction check succeeded.
Running transaction test
The downloaded packages were saved in cache until the next successful transaction.
You can remove cached packages by executing 'yum clean packages'.
Error: Transaction test error:
  file /usr/share/mysql/charsets/Index.xml from install of mysql-common-8.0.17-3.module_el8.0.0+181+899d6349.x86_64 conflicts with file f                                                                                                    rom package mariadb-common-3:10.3.17-1.module_el8.1.0+257+48736ea6.x86_64
  file /usr/share/mysql/charsets/armscii8.xml from install of mysql-common-8.0.17-3.module_el8.0.0+181+899d6349.x86_64 conflicts with fil                                                                                                    e from package mariadb-common-3:10.3.17-1.module_el8.1.0+257+48736ea6.x86_64
  file /usr/share/mysql/charsets/ascii.xml from install of mysql-common-8.0.17-3.module_el8.0.0+181+899d6349.x86_64 conflicts with file f                                                                                                    rom package mariadb-common-3:10.3.17-1.module_el8.1.0+257+48736ea6.x86_64
  file /usr/share/mysql/charsets/cp1250.xml from install of mysql-common-8.0.17-3.module_el8.0.0+181+899d6349.x86_64 conflicts with file                                                                                                     from package mariadb-common-3:10.3.17-1.module_el8.1.0+257+48736ea6.x86_64
  file /usr/share/mysql/charsets/cp1251.xml from install of mysql-common-8.0.17-3.module_el8.0.0+181+899d6349.x86_64 conflicts with file                                                                                                     from package mariadb-common-3:10.3.17-1.module_el8.1.0+257+48736ea6.x86_64
  file /usr/share/mysql/charsets/cp1256.xml from install of mysql-common-8.0.17-3.module_el8.0.0+181+899d6349.x86_64 conflicts with file                                                                                                     from package mariadb-common-3:10.3.17-1.module_el8.1.0+257+48736ea6.x86_64
  file /usr/share/mysql/charsets/cp1257.xml from install of mysql-common-8.0.17-3.module_el8.0.0+181+899d6349.x86_64 conflicts with file                                                                                                     from package mariadb-common-3:10.3.17-1.module_el8.1.0+257+48736ea6.x86_64
  file /usr/share/mysql/charsets/cp850.xml from install of mysql-common-8.0.17-3.module_el8.0.0+181+899d6349.x86_64 conflicts with file f                                                                                                    rom package mariadb-common-3:10.3.17-1.module_el8.1.0+257+48736ea6.x86_64
  file /usr/share/mysql/charsets/cp852.xml from install of mysql-common-8.0.17-3.module_el8.0.0+181+899d6349.x86_64 conflicts with file f                                                                                                    rom package mariadb-common-3:10.3.17-1.module_el8.1.0+257+48736ea6.x86_64
  file /usr/share/mysql/charsets/cp866.xml from install of mysql-common-8.0.17-3.module_el8.0.0+181+899d6349.x86_64 conflicts with file f                                                                                                    rom package mariadb-common-3:10.3.17-1.module_el8.1.0+257+48736ea6.x86_64
  file /usr/share/mysql/charsets/dec8.xml from install of mysql-common-8.0.17-3.module_el8.0.0+181+899d6349.x86_64 conflicts with file fr                                                                                                    om package mariadb-common-3:10.3.17-1.module_el8.1.0+257+48736ea6.x86_64
  file /usr/share/mysql/charsets/geostd8.xml from install of mysql-common-8.0.17-3.module_el8.0.0+181+899d6349.x86_64 conflicts with file                                                                                                     from package mariadb-common-3:10.3.17-1.module_el8.1.0+257+48736ea6.x86_64
  file /usr/share/mysql/charsets/greek.xml from install of mysql-common-8.0.17-3.module_el8.0.0+181+899d6349.x86_64 conflicts with file f                                                                                                    rom package mariadb-common-3:10.3.17-1.module_el8.1.0+257+48736ea6.x86_64
  file /usr/share/mysql/charsets/hebrew.xml from install of mysql-common-8.0.17-3.module_el8.0.0+181+899d6349.x86_64 conflicts with file                                                                                                     from package mariadb-common-3:10.3.17-1.module_el8.1.0+257+48736ea6.x86_64
  file /usr/share/mysql/charsets/hp8.xml from install of mysql-common-8.0.17-3.module_el8.0.0+181+899d6349.x86_64 conflicts with file fro                                                                                                    m package mariadb-common-3:10.3.17-1.module_el8.1.0+257+48736ea6.x86_64
  file /usr/share/mysql/charsets/keybcs2.xml from install of mysql-common-8.0.17-3.module_el8.0.0+181+899d6349.x86_64 conflicts with file                                                                                                     from package mariadb-common-3:10.3.17-1.module_el8.1.0+257+48736ea6.x86_64
  file /usr/share/mysql/charsets/koi8r.xml from install of mysql-common-8.0.17-3.module_el8.0.0+181+899d6349.x86_64 conflicts with file f                                                                                                    rom package mariadb-common-3:10.3.17-1.module_el8.1.0+257+48736ea6.x86_64
  file /usr/share/mysql/charsets/koi8u.xml from install of mysql-common-8.0.17-3.module_el8.0.0+181+899d6349.x86_64 conflicts with file f                                                                                                    rom package mariadb-common-3:10.3.17-1.module_el8.1.0+257+48736ea6.x86_64
  file /usr/share/mysql/charsets/latin1.xml from install of mysql-common-8.0.17-3.module_el8.0.0+181+899d6349.x86_64 conflicts with file                                                                                                     from package mariadb-common-3:10.3.17-1.module_el8.1.0+257+48736ea6.x86_64
  file /usr/share/mysql/charsets/latin2.xml from install of mysql-common-8.0.17-3.module_el8.0.0+181+899d6349.x86_64 conflicts with file                                                                                                     from package mariadb-common-3:10.3.17-1.module_el8.1.0+257+48736ea6.x86_64
  file /usr/share/mysql/charsets/latin5.xml from install of mysql-common-8.0.17-3.module_el8.0.0+181+899d6349.x86_64 conflicts with file                                                                                                     from package mariadb-common-3:10.3.17-1.module_el8.1.0+257+48736ea6.x86_64
  file /usr/share/mysql/charsets/latin7.xml from install of mysql-common-8.0.17-3.module_el8.0.0+181+899d6349.x86_64 conflicts with file                                                                                                     from package mariadb-common-3:10.3.17-1.module_el8.1.0+257+48736ea6.x86_64
  file /usr/share/mysql/charsets/macce.xml from install of mysql-common-8.0.17-3.module_el8.0.0+181+899d6349.x86_64 conflicts with file f                                                                                                    rom package mariadb-common-3:10.3.17-1.module_el8.1.0+257+48736ea6.x86_64
  file /usr/share/mysql/charsets/macroman.xml from install of mysql-common-8.0.17-3.module_el8.0.0+181+899d6349.x86_64 conflicts with fil                                                                                                    e from package mariadb-common-3:10.3.17-1.module_el8.1.0+257+48736ea6.x86_64
  file /usr/share/mysql/charsets/swe7.xml from install of mysql-common-8.0.17-3.module_el8.0.0+181+899d6349.x86_64 conflicts with file fr                                                                                                    om package mariadb-common-3:10.3.17-1.module_el8.1.0+257+48736ea6.x86_64

Comment 2 Fedora Admin user for bugzilla script actions 2021-02-20 00:05:35 UTC
This package has changed maintainer in Fedora. Reassigning to the new maintainer of this component.

Comment 3 Fedora Update System 2021-04-02 10:07:57 UTC
FEDORA-EPEL-2021-a32c50ac2c has been submitted as an update to Fedora EPEL 8. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2021-a32c50ac2c

Comment 4 Fedora Update System 2021-04-03 01:26:37 UTC
FEDORA-EPEL-2021-a32c50ac2c has been pushed to the Fedora EPEL 8 testing repository.

You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2021-a32c50ac2c

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 5 Fedora Update System 2021-04-06 01:29:17 UTC
FEDORA-EPEL-2021-a32c50ac2c has been pushed to the Fedora EPEL 8 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.