Bug 1868619 - [oc] go version for the oc client is different for the one installed via RPM and extracted through payload.
Summary: [oc] go version for the oc client is different for the one installed via RPM ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Release
Version: 4.6
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: 4.6.0
Assignee: Luke Meyer
QA Contact: RamaKasturi
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-08-13 10:09 UTC by RamaKasturi
Modified: 2020-10-27 16:28 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:28:09 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:28:26 UTC

Description RamaKasturi 2020-08-13 10:09:31 UTC
Description of problem:
Go version for the oc client is shown as go1.13.4 for the one installed via RPM where as shown go1.14.4 for the one extracted through payload.

Version-Release number of selected component (if applicable):
Client Version: 4.6.0-202008120152.p0-ddbae76
Server Version: 4.6.0-0.nightly-2020-08-12-140703
Kubernetes Version: v1.19.0-rc.2+3d1d343-dirty

How reproducible:
Always

Steps to Reproduce:
1) Install latest 4.6 oc client RPM
2) Download oc client from the payload page 4.6.0-0.nightly-2020-08-12-140703
3) Extract the oc client from the downloaded payload
4) Run oc version -o yaml using the RPM
5) Run oc version -o yaml using the downloaded oc client.


Actual results:
go version differs for the one installed via RPM and the one extacted from payload.

oc version -o yaml from the RPM:
=================================
[ramakasturinarra@dhcp35-60 ~]$ oc version -o yaml
clientVersion:
  buildDate: "2020-08-12T02:20:31Z"
  compiler: gc
  gitCommit: ddbae76ae1c909f232bac2b0a5a02cc6a47a7986
  gitTreeState: clean
  gitVersion: 4.6.0-202008120152.p0-ddbae76
  goVersion: go1.13.4
  major: ""
  minor: ""
  platform: linux/amd64
openshiftVersion: 4.6.0-0.nightly-2020-08-12-140703
serverVersion:
  buildDate: "2020-08-12T03:41:19Z"
  compiler: gc
  gitCommit: 3d1d343fda38b6126d50f046dab80780814d039a
  gitTreeState: dirty
  gitVersion: v1.19.0-rc.2+3d1d343-dirty
  goVersion: go1.14.4
  major: "1"
  minor: 19+
  platform: linux/amd64

oc version -o yaml from the one extracted from payload:
=======================================================
[ramakasturinarra@dhcp35-60 ~]$ /home/ramakasturinarra/Downloads/openshift-client-linux-4.6.0-0.nightly-2020-08-12-040451/oc  version -o yaml
clientVersion:
  buildDate: "2020-08-12T02:53:55Z"
  compiler: gc
  gitCommit: ddbae76ae1c909f232bac2b0a5a02cc6a47a7986
  gitTreeState: clean
  gitVersion: openshift-clients-4.6.0-202006250705.p0-73-gddbae76ae
  goVersion: go1.14.4
  major: ""
  minor: ""
  platform: linux/amd64
openshiftVersion: 4.6.0-0.nightly-2020-08-12-140703
releaseClientVersion: 4.6.0-0.nightly-2020-08-12-040451
serverVersion:
  buildDate: "2020-08-12T03:41:19Z"
  compiler: gc
  gitCommit: 3d1d343fda38b6126d50f046dab80780814d039a
  gitTreeState: dirty
  gitVersion: v1.19.0-rc.2+3d1d343-dirty
  goVersion: go1.14.4
  major: "1"
  minor: 19+
  platform: linux/amd64

Expected results:
go version from the RPM should also show go1.14.4

Additional info:

Comment 1 Maciej Szulik 2020-08-17 11:47:15 UTC
I'm guessing ART needs to catch up with the builds.

Comment 2 Luke Meyer 2020-08-18 20:09:34 UTC
Thanks for pointing this out, our RPM buildroot isn't configured correctly. Waiting on https://projects.engineering.redhat.com/browse/CLOUDBLD-2306 to fix it.

Comment 3 Luke Meyer 2020-08-21 20:11:49 UTC
This should be fixed by now. Actually the versions may be different depending on whether you are using the el7 or el8 RPM - el8 has a newer golang compiler available, el7 still in progress.

Comment 6 RamaKasturi 2020-08-27 06:08:54 UTC
Verified in the payload below and i see that go version is displayed correctly which is go1.14.4 when using the RPM installed

[ramakasturinarra@dhcp35-60 ~]$ oc version -o yaml
clientVersion:
  buildDate: "2020-08-26T07:52:17Z"
  compiler: gc
  gitCommit: 931d20f944565ad2eadea9afecddbe657e164267
  gitTreeState: clean
  gitVersion: 4.6.0-202008260718.p0-931d20f
  goVersion: go1.14.4
  major: ""
  minor: ""
  platform: linux/amd64
openshiftVersion: 4.6.0-0.nightly-2020-08-25-222652
serverVersion:
  buildDate: "2020-08-25T13:43:16Z"
  compiler: gc
  gitCommit: aaf4ce1cf2d4201a23e332030ccfeab6c17351fd
  gitTreeState: dirty
  gitVersion: v1.19.0-rc.2+aaf4ce1-dirty
  goVersion: go1.14.4
  major: "1"
  minor: 19+
  platform: linux/amd64

Based on the above moving the bug to verified state.

Comment 8 errata-xmlrpc 2020-10-27 16:28:09 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.