Bug 1868717 - Syntax error on line 323 interface [type=INTERFACE] on updating a policy package
Summary: Syntax error on line 323 interface [type=INTERFACE] on updating a policy package
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: policycoreutils
Version: 8.3
Hardware: Unspecified
OS: Linux
low
low
Target Milestone: rc
: 8.0
Assignee: Vit Mojzis
QA Contact: Milos Malik
Khushbu Borole
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-08-13 15:11 UTC by Zdenek Pytela
Modified: 2021-05-18 15:09 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
.Fixed SELinux policy interface parser Previously, the policy interface parser caused syntax error messages to appear when installing a custom policy that contained an `ifndef` block in its interface file. This update improves the interface file parsing, and thus resolves this issue.
Clone Of:
Environment:
Last Closed: 2021-05-18 15:09:18 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)

Description Zdenek Pytela 2020-08-13 15:11:37 UTC
Description of problem:
When updating or installing a specific selinux-policy-devel package, the following errors appear:
Running transaction
  Preparing        :                                                                         1/1
  Upgrading        : selinux-policy-3.14.3-52.el8.noarch                                     1/6
  Running scriptlet: selinux-policy-3.14.3-52.el8.noarch                                     1/6
  Upgrading        : selinux-policy-devel-3.14.3-52.el8.noarch                               2/6
  Running scriptlet: selinux-policy-devel-3.14.3-52.el8.noarch                               2/6
/usr/share/selinux/devel/include/contrib/ipa.if: Syntax error on line 323 interface [type=INTERFACE]
/usr/share/selinux/devel/include/contrib/ipa.if: Syntax error on line 329 ' [type=SQUOTE]
 
The update continues without any apparent problem. As /usr/bin/sepolgen-ifgen is the only command executed in the postinstall scriptlet, it may not work out properly interface definition inside a conditional block:

   322  ifndef(`ipa_helper_noatsecure',`
   323      interface(`ipa_helper_noatsecure',`
   324          gen_require(`
   325              type ipa_helper_t;
   326          ')
   327
   328          allow $1 ipa_helper_t:process { noatsecure };
   329      ')
   330  ')

Version-Release number of selected component (if applicable):
policycoreutils-devel-2.9-9.el8.x86_64

How reproducible:
always

Steps to Reproduce:
1. dnf update selinux-policy-3.14.3-52.el8.noarch
2.
3.

Actual results:
2 errors appear

Expected results:
no error appears

Additional info:

Comment 6 Petr Lautrbach 2021-01-26 15:10:51 UTC
https://patchwork.kernel.org/project/selinux/patch/20210122152552.405237-1-vmojzis@redhat.com/  acked. Feel free to push and build

Comment 22 errata-xmlrpc 2021-05-18 15:09:18 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (policycoreutils bug fix and enhancement update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:1715


Note You need to log in before you can comment on or make changes to this bug.