Bug 186872 - Evolution time zone data is incorrect
Evolution time zone data is incorrect
Status: CLOSED DUPLICATE of bug 137230
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthew Barnes
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-27 01:55 EST by n0dalus
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-05 05:42:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Demonstration of problem (80.47 KB, image/png)
2006-03-30 23:06 EST, Malcolm Tredinnick
no flags Details

  None (edit)
Description n0dalus 2006-03-27 01:55:43 EST
Description of problem:
Last year it was announced that certain Australian states would have daylight
savings moved a week for a sports event. While the timezone information in FC4
and FC5 have been updated or distributed with fixes for this, evolution gets the
time an hour out now in both releases. After next week the problem will be
"gone", but it still points to an underlying issue in the way Evolution is
coming up with timezone data.

Version-Release number of selected component (if applicable):
evolution-2.2.3-2.fc4
evolution-2.6.0-1

Steps to Reproduce:
1. Change time zone to Australia/Adelaide
2. Change evolution time zone to Australia/Adelaide
3. Open evolution's calendar to the current date, and note where the red moving
line is in FC5, or for FC4, make an appointment and then see what time the
appointment is listed in the gnome clock applet.
  
Actual results:
Red line or appointment time is 1 hour out.

Expected results:
Red line or appointment time is at the correct time.
Comment 1 Malcolm Tredinnick 2006-03-30 23:06:50 EST
Created attachment 127098 [details]
Demonstration of problem

Confirmation/demonstration of the problem. Note that the appointment is entered
at the correct time (1600 - 1700) in Evolution's contacts, but shows up
incorrectly in the panel applet. So the problem seems to lie in
evolution-data-server's time computations. I am amazed that e-d-s is trying to
recompute information that the OS already knows for certain.
Comment 2 Edward Rudd 2006-04-14 13:16:04 EDT
This issue is caused becuase Evolution uses it's own internal set of timezones
instead of the system set of timezone..    Should this be filed @ gnome.org
under evolution???
Comment 3 Dave Malcolm 2007-01-08 10:13:54 EST
Thanks for filing this bug report.  I'm sorry that it has gone for so long
without activity; it was incorrectly assigned to me by bugzilla.

Reassigning to mbarnes; once again, my apologies for my lack of activity on this
bug.
Comment 4 Johan Kok 2007-02-05 05:42:01 EST
This seems to be the same issue as bug #137230. Closing this one as a duplicate.

*** This bug has been marked as a duplicate of 137230 ***

Note You need to log in before you can comment on or make changes to this bug.