Bug 1868724 - Monitoring: Alerts.Monitoring: Alerts "after all" hook for "displays and filters the Alerts list page, links to detail pages"
Summary: Monitoring: Alerts.Monitoring: Alerts "after all" hook for "displays and filt...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.6
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.6.0
Assignee: David Taylor
QA Contact: Yadan Pei
URL:
Whiteboard:
: 1869337 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-08-13 15:28 UTC by Micah Abbott
Modified: 2020-10-27 16:28 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Monitoring: Alerts.Monitoring: Alerts "after all" hook for "displays and filters the Alerts list page, links to detail pages" Monitoring: Alerts.Monitoring: Alerts "before all" hook for "displays and filters the Alerts list page, links to detail pages" Namespace "before all" hook for "lists, creates, and deletes" Namespace "after all" hook for "lists, creates, and deletes"
Last Closed: 2020-10-27 16:28:09 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 6319 0 None closed Bug 1868724: Fix cypress test failures 2020-12-04 14:24:40 UTC
Github openshift console pull 6449 0 None closed Revert "Bug 1868724: Fix cypress test failures" 2020-12-04 14:24:40 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:28:26 UTC

Description Micah Abbott 2020-08-13 15:28:29 UTC
test:
Monitoring: Alerts.Monitoring: Alerts "after all" hook for "displays and filters the Alerts list page, links to detail pages" 

is failing frequently in CI, see search results:

https://search.ci.openshift.org/?search=displays+and+filters+the+Alerts+list+page%2C+links+to+detail+pages&maxAge=168h&context=1&type=bug%2Bjunit&name=4.6&maxMatches=5&maxBytes=20971520&groupBy=job

(Sippy search is a little fuzzy on this particular test)

Found examples of failures here:

https://prow.ci.openshift.org/view/gs/origin-ci-test/logs/release-openshift-ocp-installer-console-aws-4.6/1293625806131564544

https://prow.ci.openshift.org/view/gs/origin-ci-test/logs/release-openshift-ocp-installer-console-aws-4.6/1293588526423609344

https://prow.ci.openshift.org/view/gs/origin-ci-test/logs/release-openshift-ocp-installer-console-aws-4.6/1293577241166352384


Failing test looks like:

```
────────────────────────────────────────────────────────────────────────────────────────────────────
                                                                                                    
  Running:  monitoring/monitoring.spec.ts                                                   (3 of 3)


  Monitoring: Alerts
  Logging into IDP kube:admin, using baseUrl https://console-openshift-console.apps.ci-op-xcw97trg-422ae.origin-ci-int-aws.dev.rhcloud.com
    1) "before all" hook for "displays and filters the Alerts list page, links to detail pages"
    2) "after all" hook for "displays and filters the Alerts list page, links to detail pages"


  0 passing (33s)
  2 failing

  1) Monitoring: Alerts
       "before all" hook for "displays and filters the Alerts list page, links to detail pages":
     AssertionError: Timed out retrying: Expected to find element: `[data-test-id="login"]`, but never found it.

Because this error occurred during a `before all` hook we are skipping the remaining tests in the current suite: `Monitoring: Alerts`
      at Context.eval (https://console-openshift-console.apps.ci-op-xcw97trg-422ae.origin-ci-int-aws.dev.rhcloud.com/__cypress/tests?p=tests/monitoring/monitoring.spec.ts:1915:32)

  2) Monitoring: Alerts
       "after all" hook for "displays and filters the Alerts list page, links to detail pages":
     CypressError: `cy.click()` failed because it requires a DOM element.

The subject received was:

  > `undefined`

The previous command that ran was:

  > `cy.get()`

Because this error occurred during a `after all` hook we are skipping the remaining tests in the current suite: `Monitoring: Alerts`
      at ensureElement (https://console-openshift-console.apps.ci-op-xcw97trg-422ae.origin-ci-int-aws.dev.rhcloud.com/__cypress/runner/cypress_runner.js:159904:24)
      at validateType (https://console-openshift-console.apps.ci-op-xcw97trg-422ae.origin-ci-int-aws.dev.rhcloud.com/__cypress/runner/cypress_runner.js:159728:16)
      at Object.ensureSubjectByType (https://console-openshift-console.apps.ci-op-xcw97trg-422ae.origin-ci-int-aws.dev.rhcloud.com/__cypress/runner/cypress_runner.js:159770:11)
      at pushSubjectAndValidate (https://console-openshift-console.apps.ci-op-xcw97trg-422ae.origin-ci-int-aws.dev.rhcloud.com/__cypress/runner/cypress_runner.js:167481:15)
      at Context.<anonymous> (https://console-openshift-console.apps.ci-op-xcw97trg-422ae.origin-ci-int-aws.dev.rhcloud.com/__cypress/runner/cypress_runner.js:167809:18)
  From Your Spec Code:
      at Object.clickPageActionFromDropdown (https://console-openshift-console.apps.ci-op-xcw97trg-422ae.origin-ci-int-aws.dev.rhcloud.com/__cypress/tests?p=tests/monitoring/monitoring.spec.ts:1943:50)
      at Context.eval (https://console-openshift-console.apps.ci-op-xcw97trg-422ae.origin-ci-int-aws.dev.rhcloud.com/__cypress/tests?p=tests/monitoring/monitoring.spec.ts:2036:17)




  (Results)

  ┌────────────────────────────────────────────────────────────────────────────────────────────────┐
  │ Tests:        2                                                                                │
  │ Passing:      0                                                                                │
  │ Failing:      1                                                                                │
  │ Pending:      0                                                                                │
  │ Skipped:      1                                                                                │
  │ Screenshots:  2                                                                                │
  │ Video:        true                                                                             │
  │ Duration:     33 seconds                                                                       │
  │ Spec Ran:     monitoring/monitoring.spec.ts                                                    │
  └────────────────────────────────────────────────────────────────────────────────────────────────┘


  (Screenshots)

  -  /go/src/github.com/openshift/console/frontend/gui_test_screenshots/cypress/scree     (1280x720)
     nshots/monitoring/monitoring.spec.ts/Monitoring Alerts -- displays and filters t               
     he Alerts list page, links to detail pages -- before all hook (failed).png                     
  -  /go/src/github.com/openshift/console/frontend/gui_test_screenshots/cypress/scree     (1280x720)
     nshots/monitoring/monitoring.spec.ts/Monitoring Alerts -- displays and filters t               
     he Alerts list page, links to detail pages -- after all hook (failed).png                      


  (Video)

  -  Started processing:  Compressing to 32 CRF                                                     
  -  Finished processing: /go/src/github.com/openshift/console/frontend/gui_test_scre    (2 seconds)
                          enshots/cypress/videos/monitoring/monitoring.spec.ts.mp4                  


================================================================================
```

Comment 1 Samuel Padgett 2020-08-13 17:30:57 UTC
The failing tests were fixed yesterday by https://github.com/openshift/console/pull/6319. The linked jobs were started before that PR merged.

Comment 5 XiaochuanWang 2020-08-17 06:37:29 UTC
From the CI search failing logs: https://search.ci.openshift.org/?search=displays+and+filters+the+Alerts+list+page%2C+links+to+detail+pages&maxAge=168h&context=1&type=bug%2Bjunit&name=4.6&maxMatches=5&maxBytes=20971520&groupBy=job

The Latest failure is still #1293625806131564544
This does not reproduces again. Will move this issue to be Verified.
Feel free to reopen if hit on this issue again. Thanks

Comment 6 Samuel Padgett 2020-08-17 20:02:56 UTC
*** Bug 1869337 has been marked as a duplicate of this bug. ***

Comment 7 Samuel Padgett 2020-08-26 17:26:20 UTC
Moving back to assigned. We can revert the test workaround now that we've fixed the underlying logout problem in Bug 1869966.

Comment 8 David Taylor 2020-08-26 17:44:07 UTC
Some of these issues were fixed via: https://github.com/openshift/console/pull/6372.
Some are due to: https://bugzilla.redhat.com/show_bug.cgi?id=1869966, which has been verified.
Now that https://github.com/openshift/console/pull/6431 has merged (logout issue), I see Sam is trying to revert the workaround in this PR: https://github.com/openshift/console/pull/6449

Comment 9 Samuel Padgett 2020-08-27 13:37:26 UTC
This Bug was specifically for CI failures due to the logout change. Dave, we should open a separate Bugzilla bug for your other PR.

Comment 13 errata-xmlrpc 2020-10-27 16:28:09 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.