Bug 1868794 - Add host logs under must-gather for networking
Summary: Add host logs under must-gather for networking
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Networking
Version: 4.6
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ---
: 4.6.0
Assignee: Ricardo Carrillo Cruz
QA Contact: Anurag saxena
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-08-13 19:55 UTC by Anurag saxena
Modified: 2020-10-27 16:28 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:28:34 UTC
Target Upstream Version:
rbrattai: needinfo-


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift must-gather pull 175 0 None open Bug 1868794: Gather OVS logs from host 2020-09-29 21:24:52 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:28:52 UTC

Description Anurag saxena 2020-08-13 19:55:36 UTC
Description of problem: Tim and I had a short discussion on this. Is it possible to add host logs as well under oc adm for networking? Specially we are running OVS on host now, it would make sense to collect host logs.

If its not a candidate for `oc adm must-gather`, then i guess its definitely a candidate for just networking logs `oc adm must-gather –keep -- /usr/bin/gather_network_logs`


Version-Release number of selected component (if applicable):4.6 and back


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Ricardo Carrillo Cruz 2020-08-21 14:05:15 UTC
Per Tim Rozet, logs are munged and hard to read, we should have per worker files.

Comment 2 Ricardo Carrillo Cruz 2020-09-09 10:42:06 UTC
Anurag, when you say host logs can you be more specific?
Stuff from /var/log and/or something else?

Comment 3 Ross Brattain 2020-09-09 12:33:53 UTC
host OVS logs. "Specially we are running OVS on host now, it would make sense to collect host logs."

openvswitch.service
ovsdb-server.service
ovs-vswitchd.service

and probably just regular journalctl logs

Comment 4 Ricardo Carrillo Cruz 2020-09-10 14:59:29 UTC
Gotcha, thanks.
I'll try to have the PR up.

Comment 6 Ross Brattain 2020-09-25 00:20:29 UTC
Verified on 4.6.0-0.nightly-2020-09-24-074159


./network_logs/qe-o46g4a-8ks9s-master-1.c.openshift-qe.internal_ovsdb_log
./network_logs/qe-o46g4a-8ks9s-master-0.c.openshift-qe.internal_ovsdb_log
./network_logs/qe-o46g4a-8ks9s-master-1.c.openshift-qe.internal_ovs_vswitchd_log
./network_logs/qe-o46g4a-8ks9s-master-0.c.openshift-qe.internal_ovs_vswitchd_log
./network_logs/qe-o46g4a-8ks9s-master-2.c.openshift-qe.internal_ovs_vswitchd_log
./network_logs/qe-o46g4a-8ks9s-master-2.c.openshift-qe.internal_ovsdb_log
./network_logs/qe-o46g4a-8ks9s-worker-a-n5lzl.c.openshift-qe.internal_ovs_vswitchd_log
./network_logs/qe-o46g4a-8ks9s-worker-a-n5lzl.c.openshift-qe.internal_ovsdb_log
./network_logs/qe-o46g4a-8ks9s-worker-b-kqzpx.c.openshift-qe.internal_ovs_vswitchd_log
./network_logs/qe-o46g4a-8ks9s-worker-b-kqzpx.c.openshift-qe.internal_ovsdb_log
./network_logs/qe-o46g4a-8ks9s-worker-c-7kdm8.c.openshift-qe.internal_ovs_vswitchd_log
./network_logs/qe-o46g4a-8ks9s-worker-c-7kdm8.c.openshift-qe.internal_ovsdb_log

Comment 9 errata-xmlrpc 2020-10-27 16:28:34 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.