Bug 186880 - Printer Epson CX3200 does not work
Printer Epson CX3200 does not work
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: cups (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-27 03:41 EST by Pascal Viot
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-04 13:44:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
part of /var/logcups/error_log (2.34 KB, text/plain)
2006-03-27 11:40 EST, Pascal Viot
no flags Details
/var/log/cups/error_log (20.33 KB, application/octet-stream)
2006-04-04 12:14 EDT, Pascal Viot
no flags Details
console.perms file (933 bytes, application/octet-stream)
2006-04-04 13:31 EDT, Pascal Viot
no flags Details

  None (edit)
Description Pascal Viot 2006-03-27 03:41:04 EST
Description of problem:
My printer Espon CX3200 does not work with FC5. The message in
/var/log/cups/error_log is
Listening to 127.0.0.1:631 on fd 0...
E [27/Mar/2006:10:35:55 +0200] Unable to set ACLs on root certificate
"/var/run/cups/certs/0" - Operation not supported


Version-Release number of selected component (if applicable):
cups-libs-1.2-0.1.b2.1 and also 
cups-libs-1.2-0.1.b2.6
How reproducible:


Steps to Reproduce:
1. The printer has been configured with system-config-printer
2. 
3.
  
Actual results:


Expected results:



Additional info:
When I use http://localhost:631 
the message is Error closing renderer
Comment 1 Tim Waugh 2006-03-27 03:43:45 EST
Fixing version.
Comment 2 Tim Waugh 2006-03-27 05:24:32 EST
What CPU type are you using?  Is it x86_64 perhaps?
Comment 3 Pascal Viot 2006-03-27 09:11:27 EST
AMD X2
Comment 4 Tim Waugh 2006-03-27 10:11:26 EST
Should be fixed in the foomatic I built on Friday, 3.0.2-34.
Comment 5 Pascal Viot 2006-03-27 11:40:32 EST
Created attachment 126832 [details]
part of /var/logcups/error_log
Comment 6 Tim Waugh 2006-04-03 06:12:51 EDT
Does this work now?
Comment 7 Pascal Viot 2006-04-03 11:36:46 EDT
It does not work yet. 
I can add few things.
I installed on my (centrino) Laptop FC5 and I plug my printer on the usb device.
I can print from my laptop. Moreover,  from my Opteron computer, I see the my
printer with cups and I can print by using the network and hence the printer
connected to my laptop.
This means both that cups works on X86_64 for printers on the network
but not connected locally 
I also notice a curious message in /var/log/messages when I plug my printerApr 
3 17:25:41 anacan4 kernel: usb 1-1: new full speed USB device using ohci_hc    
                                       d and address 3
Apr  3 17:25:41 anacan4 kernel: usb 1-1: configuration #1 chosen from 1 choice
Apr  3 17:25:41 anacan4 kernel: drivers/usb/class/usblp.c: usblp0: USB Bidirecti
                                           onal printer dev 3 if 1 alt 0 proto 2
vid 0x04B8 pid 0x0802
Apr  3 17:25:41 anacan4 kernel: usbcore: registered new driver usblp
Apr  3 17:25:41 anacan4 kernel: drivers/usb/class/usblp.c: v0.13: USB Printer De
                                           vice Class driver
Apr  3 17:25:50 anacan4 hpiod: ParDevice::nibble_read failed: Input/output error
                                           
I scanned Google and I found that such a message occurs in bugzilla, #183433. 

the typical error_log message is
E [03/Apr/2006:17:30:16 +0200] [Job 10] Loading NimbusRomNo9L-Regu font from
/usr/share/fonts/default/Type1/n021003l.pfb... 3244808 1931530 1780296 478707 1
done.
E [03/Apr/2006:17:30:16 +0200] [Job 10] Using NimbusRomanNo9L-Regu font for
NimbusRomNo9L-Regu.
E [03/Apr/2006:17:30:16 +0200] [Job 10] Loading NimbusSanL-ReguCondItal font
from /usr/share/fonts/default/Type1/n019063l.pfb... 3399192 2079248 1800480
502607 1 done.
E [03/Apr/2006:17:30:18 +0200] [Job 10] KID3 exited with status 0
E [03/Apr/2006:17:30:18 +0200] [Job 10] KID4 exited with status 9
E [03/Apr/2006:17:30:18 +0200] [Job 10] Process dying with "error closing
*main::STDOUT", exit stat: 9
E [03/Apr/2006:17:30:18 +0200] [Job 10] error: Relais bris�(pipe) (32)
E [03/Apr/2006:17:30:18 +0200] [Job 10] error closing *main::STDOUT
E [03/Apr/2006:17:30:18 +0200] [Job 10] Renderer exit stat: 9
E [03/Apr/2006:17:30:18 +0200] [Job 10] KID3 finished
E [03/Apr/2006:17:30:18 +0200] [Job 10] Renderer process finished
E [03/Apr/2006:17:30:18 +0200] [Job 10] Killing process 3419 (KID3)
E [03/Apr/2006:17:30:18 +0200] [Job 10] Process dying with "Error closing
renderer", exit stat: 9
E [03/Apr/2006:17:30:18 +0200] [Job 10] error: Mauvais descripteur de fichier (9)
E [03/Apr/2006:17:30:18 +0200] [Job 10] Error closing renderer
E [03/Apr/2006:17:30:18 +0200] PID 3416 (/usr/lib/cups/filter/foomatic-rip)
stopped with status 9!

Thanks for your interest
Sincerely yours, Pascal 
Comment 8 Tim Waugh 2006-04-04 11:36:46 EDT
Should be fixed in cups-1.2-0.2.rc1.6 (devel) and cups-1.2-0.2.rc1.2.6 (FC-5
updates-testing).

The x86_64 devel packages are here:

  ftp://people.redhat.com/twaugh/tmp/cups-devel/x86_64/

if you would like to try them before tomorrow's rawhide tree is pushed.
Comment 9 Pascal Viot 2006-04-04 12:14:06 EDT
Created attachment 127303 [details]
/var/log/cups/error_log
Comment 10 Pascal Viot 2006-04-04 12:19:22 EDT
The new version of cups does not fix the problem, but (see log file) I noted that
the CUPS environnement variables do not start with /usr/lib64 but with /usr/lib
and could explain my problem. Since the Espon CX3200 is also an scanner, I tried
it and it works.
If the problem is due to the environnement variables, what the configuration file
where I can change the path
Thanks again for your help
Comment 11 Tim Waugh 2006-04-04 12:33:58 EDT
The paths '/usr/lib/cups/backend' and '/usr/lib/cups/filter' are correct in CUPS
1.2, even on x86_64 -- those directories always contain executables and not
libraries.

The problem is this line in the log:

E [04/Apr/2006:18:02:26 +0200] [Job 31] Unable to open USB device
"usb:/dev/usb/lp0": Permission denied

Please show me the output of this command:

ls -l /dev/usb/lp0
Comment 12 Pascal Viot 2006-04-04 12:43:29 EDT
ls -l /dev/usb/lp0
crw------- 1 viot root 180, 0 avr  4 13:34 /dev/usb/lp0

I do not undertand why I am the owner???
Comment 13 Tim Waugh 2006-04-04 13:06:51 EDT
Please attach /etc/security/console.perms.  You may need to do this as root first:

cat /etc/security/console.perms >/tmp/console.perms
chmod a+r /tmp/console.perms

It certainly isn't normal that you are the owner.  The ownership should be
root:lp, and this is the reason you cannot print.
Comment 14 Pascal Viot 2006-04-04 13:31:39 EDT
Created attachment 127306 [details]
console.perms file

After some minutes, I have
ls -l /dev/usb/lp0
crw------- 1 viot lp 180, 0 avr  4 18:54 /dev/usb/lp0

but 
lpq
lw is not ready
Rank	Owner	Job	File(s) 			Total Size
1st	viot	35	hosts				1024 bytes

???
Comment 15 Tim Waugh 2006-04-04 13:44:33 EDT
Well, the lp group still can't read or write to that node.

What do you mean 'after some minutes' -- did it just change on its own?

On the FC-5 machine I have here, the permissions are correct, so I think this
must be some local modification you have made.
Comment 16 Pascal Viot 2006-04-04 17:02:02 EDT
I did not change the permissions, but I only removed the job of testpage and
sent a job from my account.
Anyway, I just found a workaround and my printer works finally
chmod o+rw /dev/usb/lp0
chmod g+rw /dev/usb/lp0

The error_log gives then
 [04/Apr/2006:22:54:55 +0200] [Job 38] KID4 exited with status 0
E [04/Apr/2006:22:54:55 +0200] [Job 38] Renderer exit stat: 0
E [04/Apr/2006:22:54:55 +0200] [Job 38] Renderer process finished
E [04/Apr/2006:22:54:55 +0200] [Job 38]
E [04/Apr/2006:22:54:55 +0200] [Job 38] Closing foomatic-rip.
D [04/Apr/2006:22:54:55 +0200] PID 7334 (/usr/lib/cups/filter/foomatic-rip)
exited with no errors.
D [04/Apr/2006:22:54:57 +0200] PID 7335 (/usr/lib/cups/backend/usb) exited with
no errors.

I do not know if theses permissions remain correct from a point of view of  a
security level, but it works.
Thanks again for your help!
I am glad of Fedora (our Beowulf (Bi-opteron) is using Fedora x86-64
http://www.lptl.jussieu.fr/) and our Nas server Redhat Enterprise.
Thanks again


Note You need to log in before you can comment on or make changes to this bug.