Bug 1869059 - jack clients can't open as a client on a running jackd instance
Summary: jack clients can't open as a client on a running jackd instance
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: jack-audio-connection-kit
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Guido Aulisi
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedFreezeException
Depends On:
Blocks: F33BetaFreezeException
TreeView+ depends on / blocked
 
Reported: 2020-08-16 04:36 UTC by Erich Eickmeyer
Modified: 2020-08-31 20:08 UTC (History)
9 users (show)

Fixed In Version: jack-audio-connection-kit-1.9.14-5.fc33
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-08-31 20:08:21 UTC
Type: Bug


Attachments (Terms of Use)

Description Erich Eickmeyer 2020-08-16 04:36:49 UTC
Description of problem:
Jack clients are unable to open as a client on running jackd instances. It seems to have started right around the time of the mass rebuild. This is affecting Fedora Jam primarily as it includes jack by default.

Version-Release number of selected component (if applicable):
F33, Rawhide

How reproducible:
Every time.

Steps to Reproduce:
1. start jackd or jackdbus
2. run jack_lsp to list jack's port

Actual results:
jack_lsp fails with:
Cannot open shm segment /jack-1000-0 (No such file or directory)
Map shared memory segments exception
JackShmReadWritePtr1::~JackShmReadWritePtr1 - Init not done for -1, skipping unlock
JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for 0, skipping unlock
Error: cannot connect to JACK, jack_client_open() failed, status = 0x21

Expected results:
Stable jack system with no errors

Additional info:
It appears as though from the logs that jack_lsp is actually connecting momentarily, but instantly crashing:
Sat Aug 15 19:53:01 2020: New client 'lsp' with PID 1575
Sat Aug 15 19:53:01 2020: Client 'lsp' with PID 1575 is out

Comment 1 Guido Aulisi 2020-08-25 14:27:58 UTC
Can you try with latest rawhide build jack-audio-connection-kit-1.9.14-5.fc34?
It has been compiled without LTO optimization.

https://koji.fedoraproject.org/koji/taskinfo?taskID=50140186

Comment 2 Erich Eickmeyer 2020-08-28 01:51:32 UTC
I can confirm that your build does indeed fix the problem. Definitely an LTO optimization issue.

Comment 3 Fedora Update System 2020-08-28 08:02:14 UTC
FEDORA-2020-43dfda58b3 has been submitted as an update to Fedora 33. https://bodhi.fedoraproject.org/updates/FEDORA-2020-43dfda58b3

Comment 4 Erich Eickmeyer 2020-08-28 16:19:35 UTC
I have requested a Beta Freeze Exception to get this moved out of testing ASAP. https://pagure.io/releng/issue/9728

Comment 5 Fedora Blocker Bugs Application 2020-08-28 16:33:44 UTC
Proposed as a Freeze Exception for 33-beta by Fedora user eeickmeyer using the blocker tracking app because:

 Build jack-audio-connection-kit-1.9.14-4.fc33, currently in main, contains a critical bug caused by LTO optimizations in which that JACK audio server fails to accept clients, rendering the entire audio infrastructure useless. jack-audio-connection-kit-1.9.14-5.fc33 was built without LTO optimizations and, therefore, does not suffer this issue. Since jack-audio-connection-kit is part of the default Fedora Jam installation, this needs to be moved from testing to main prior to Beta release. This build has been tested as working.

If this cannot be done, Fedora Jam 33 Beta will release with an unusable JACK audio server and, therefore, we may see a high number of unnecessary bug reports and bad reviews/first impressions.

Comment 6 Kamil Páral 2020-08-31 12:30:23 UTC
Accepted as a Beta freeze exception:
https://pagure.io/fedora-qa/blocker-review/issue/48

Comment 7 Fedora Update System 2020-08-31 20:08:21 UTC
FEDORA-2020-43dfda58b3 has been pushed to the Fedora 33 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.