Bug 186927 - sendmail 8.12.11-4.24.1.legacy does not provide /etc/pam.d/smtp
sendmail 8.12.11-4.24.1.legacy does not provide /etc/pam.d/smtp
Status: CLOSED DUPLICATE of bug 186277
Product: Fedora Legacy
Classification: Retired
Component: sendmail (Show other bugs)
rhl9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Fedora Legacy Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-27 10:25 EST by Steven Marzec
Modified: 2007-04-18 13:40 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-27 11:09:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steven Marzec 2006-03-27 10:25:25 EST
Description of problem:
sendmail 8.12.11-4.24.1.legacy is an upgrade offered for sendmail 8.12.8-9.90,
but it does not offer /etc/pam.d/smtp which is found in the older sendmail 
package. Instead it is replaced with /etc/pam.d/smtp.sendmail but breaks smtp 
authentication.

Version-Release number of selected component (if applicable):
8.12.11-4.24.1.legacy

How reproducible:
always

Steps to Reproduce:
1. install sendmail 8.12.8-9.90
2. setup a working smtp ssl/tls authentication setup
3. upgrade to sendmail 8.12.11-4.24.1.legacy
  
Actual results:
Users trying to send mail via smtp authenticated relay will be denied access to 
relay through server.

Expected results:
Authenticated users via smtp should be able to send outgoing mail.

Additional info:
As a workaround, I linked /etc/pam.d/smtp to /etc/pam.d/smtp.sendmail and smtp 
authentication began to work normally again.
Comment 1 David Eisenstein 2006-03-27 11:09:56 EST
Thank you for reporting this bug, Stephen.  We have proposed Red Hat
Linux 9 sendmail packages in QA that should fix this issue, and some
other issues as well.  They are posted in Bug #186277 comment #55, and we
would welcome your QA on these packages, if you have the inclination, time
and resources to do so.

You should be able to upgrade from either sendmail-8.12.8-9.90 or
sendmail-8.12.11-4.24.1.legacy to the proposed sendmail-8.12.11-4.24.3.legacy
package (download links in Bug #186277) and the issue should be resolved
either way.

Am closing this bug as a duplicate of Bug #186277 since this issue is being
worked on there.  You should automatically be added to the cc: list of that
bug as this one is closed, so you will be kept up to date on developments
and release information.

Thanks again.

*** This bug has been marked as a duplicate of 186277 ***

Note You need to log in before you can comment on or make changes to this bug.