Bug 186930 - Fix liboil build for FC5 Update
Fix liboil build for FC5 Update
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: liboil (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: John (J5) Palmieri
:
Depends On:
Blocks: FC5Update
  Show dependency treegraph
 
Reported: 2006-03-27 10:41 EST by Warren Togami
Modified: 2013-03-13 00:50 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-04 21:22:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Warren Togami 2006-03-27 10:41:22 EST
Extras got mad that we put liboil into Core without telling them, and they
proceeded to do an FE5 update which overrided our FC5 package.  I tried to
re-merge their changes into Core, but it fails to build on s390 again.  The
patch in core needs to be refactored to work with what looks like macro changes.

Please fix this in FC-5 and devel, and issue a FC5 update.
Comment 1 Ray Strode [halfline] 2006-03-27 11:07:18 EST
I'll have a look at this...
Comment 2 Ray Strode [halfline] 2006-03-27 11:53:11 EST
Built,  I'll push it into updates-testing later today.
Comment 3 Fedora Update System 2006-03-27 12:07:56 EST
liboil-0.3.8-1.fc5 has been pushed for FC4, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.
Comment 4 Ray Strode [halfline] 2006-03-27 14:04:00 EST
(ignore comment 3 which is bogus)
Comment 5 Matthias Saou 2006-03-28 04:26:28 EST
Warren : You should avoid writing things like "got mad". You indeed rebuilt
liboil for Core without telling me, the current Extras maintainer. First
problem, but nothing major, s*it happens. The other problem is that I didn't
notice, and with FC5's release getting closer and liboil 0.3.7 not building
cleanly on PPC, I needed to get it rebuilt somehow. After reporting the issue in
the liboil bugzilla, I pushed out a package based on the current CVS that fixed
the problem (that 0.3.7.1 problem). It is then that people realized that a
liboil package had appeared in Extras which was newer than the one in Core.

They didn't go mad. They just wanted to understand what happened in order to
prevent this problem from happening again, which is the right thing to do. This
case is different than the one where someone pushes a package in Core without
realizing that it was already available in Extras. You took the spec file from
Extras, doing only a small part of what should have been done at that point.

After this incident, you deleted the devel CVS branch for liboil in Extras,
which again is the right thing to do, but you did not answer to any of the
mailing-list messages related to the issue, nor send me a private email about it.

Please, next time remember to notify the Extras packager first, then delete the
devel Extras branch, and only then import and rebuild the package into Core.
This should definitely be a strict policy to be followed when adding packages to
Core.

Also, I really appreciate quick private explanations, even one-liners. A lot
more than reading the first paragraph of this bug report for instance, where you
seem to identify yourself as Core and Extras as the guys who went mad...
(re-read it, you'll understand I'm sure).
Comment 6 Warren Togami 2006-03-28 09:47:48 EST
I apologize, this has been a huge oversight on my part.  I imported liboil into
Core on behalf of the actual owner because some component required it.  But at
the time I was rushing because I was way too stressed out with too many things
going on.  I will be more careful to notify people in the proper way in the future.
Comment 7 Matthias Saou 2006-07-04 19:43:45 EDT
If things have been taken care of (and I think they have), this bug could
probably be closed now...

Note You need to log in before you can comment on or make changes to this bug.