This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 186936 - Incorrect rule for Palm devices
Incorrect rule for Palm devices
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: udev (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-27 11:01 EST by Nigel Metheringham
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-25 10:08:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Nigel Metheringham 2006-03-27 11:01:22 EST
Description of problem:
All modern palm devices with USB support create 2 ttyUSB devices on sync,
the second (higher numbered) of which is the one that can be used for
standard palm sync.  Hence it is this second one that should be symlinked to
/dev/pilot

The current ruleset tries to symlink both ttyUSB devices and tends to result in
the lower numbered one being linked in.

Version-Release number of selected component (if applicable):
udev-084-13


Additional info:
Suggest change the 2 rules involved to:-

KERNEL=="ttyUSB[13579]", SYSFS{product}=="Palm Handheld*", SYMLINK+="pilot"
KERNEL=="ttyUSB[13579]", SYSFS{product}=="palmOne Handheld*", SYMLINK+="pilot"

This will fail if another device has taken an odd number of ttyUSB devices
beforehand.  But at least it works most of the time, the current solution works
none of the time.

By modern palm devices I mean anything produced by Palm themselves which does
USB.  There are other palm powered devices (notably older Handspring models)
which do not always produce 2 ttyUSB devices or use the first one for sync, but
I assert that these will have a SYSFS{product} whcih does not match the 2
strings above, and so will be unaffected by this change.
Comment 1 Jake Gage 2006-09-01 17:53:10 EDT
The Sony Clie PEG-TH55 also creates two different devices, normally /dev/ttyUSB0
and /dev/ttyUSB1.  However, it is only the first device which can be used to
perform a standard sync, and the above rules incorrectly link /dev/pilot to the
unusable device.

I don't have a resolution for the above problem so that both devices work
properly, mainly because I don't understand the nature of the two devices being
created.  I've been reading that one is an input device and the other is an
output device from a few Web sources, but cannot verify this myself.
Comment 2 Harald Hoyer 2006-09-25 10:08:17 EDT
the application should really be fixed... udev workarounds won't help, cause the
numbering of the devices is really not fixed...

Note You need to log in before you can comment on or make changes to this bug.